banhosts: Call killall with the -s
authorJan Baier <jan.baier@amagical.net>
Wed, 18 Aug 2021 12:20:04 +0000 (14:20 +0200)
committerEtienne Champetier <champetier.etienne@gmail.com>
Wed, 8 Sep 2021 21:13:52 +0000 (17:13 -0400)
Some versions of killall do support the `killall -SIGNAL` syntax and
have only `-s SIGNAL` which should be supported everywhere.

I see the problem with *killall (PSmisc) 23.3* on latest TurrisOS 5.2

Signed-off-by: Jan Baier <jan.baier@amagical.net>
utils/banhosts/Makefile
utils/banhosts/files/updatebanhost

index 0087a6ff1ead0570b9b0660fe10c6ed1f773d81b..47a0ddbea3586b6461386a4dd8af93fd2c61265a 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=banhostlist
 PKG_VERSION:=1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_BUILD_DIR=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_MAINTAINER:=Matteo Croce <matteo@openwrt.org>
index a00d9cb6bd1bd5ddf25208dcffa99de431c06742..3930b60ada729a103c566dac2f84a02e2f1303f3 100644 (file)
@@ -6,7 +6,7 @@ gethosts() {
        logger -t "banhost[$$]" "Update $file"
        wget -qO- http://winhelp2002.mvps.org/hosts.txt |awk 'BEGIN{printf "0.0.0.0"}/^0\.0\.0\.0/{printf " "$2}END{exit(!FNR)}' >$file || exit 1
        echo -n $time >$file.time
-       exec killall -HUP dnsmasq
+       exec killall -HUP dnsmasq
 }
 
 if [ "$ACTION" = ifup -a "$INTERFACE" = wan ]; then