uanytun: remove build time/host to fix reproducible builds
authorAlexander Couzens <lynxis@fe80.eu>
Wed, 6 Dec 2017 21:55:45 +0000 (22:55 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Wed, 6 Dec 2017 21:56:41 +0000 (22:56 +0100)
Build timestamps prevents reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
net/uanytun/Makefile
net/uanytun/patches/100-reproducible-builds.patch [new file with mode: 0644]

index ddce67cbfe55626a9217d4ddfed672f73b2da966..ef7b3914d6af1a74090521eb3444c321530013a9 100644 (file)
@@ -13,7 +13,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uanytun
 PKG_VERSION:=0.3.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.anytun.org/download/
diff --git a/net/uanytun/patches/100-reproducible-builds.patch b/net/uanytun/patches/100-reproducible-builds.patch
new file mode 100644 (file)
index 0000000..a5aa864
--- /dev/null
@@ -0,0 +1,12 @@
+Index: uanytun-0.3.5/src/options.c
+===================================================================
+--- uanytun-0.3.5.orig/src/options.c
++++ uanytun-0.3.5/src/options.c
+@@ -481,7 +481,6 @@ void options_print_usage()
+ void options_print_version()
+ {
+   printf("%s\n", VERSION_STRING_0);
+-  printf("%s\n", VERSION_STRING_1);
+ }
+ void options_print(options_t* opt)