d1: Use correct module for devices with wifi
authorRaylynn Knight <rayknight@me.com>
Sat, 11 Jan 2025 05:19:59 +0000 (00:19 -0500)
committerHauke Mehrtens <hauke@hauke-m.de>
Mon, 13 Jan 2025 22:38:19 +0000 (23:38 +0100)
Devices with wifi (LicheePi RV and MangoPi MQ Pro) were using the
wrong module.  Also wpad was missing to enable using the WiFi.

Signed-off-by: Raylynn Knight <rayknight@me.com>
Link: https://github.com/openwrt/openwrt/pull/17576
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
target/linux/d1/base-files/etc/board.d/02_network
target/linux/d1/image/Makefile

index df48b431af5e2c9b504fa886f5c2fee76ab3a40b..dc61e4bde5146047564b222a754027eb197db3e1 100644 (file)
@@ -8,6 +8,10 @@
 board_config_update
 
 case "$(board_name)" in
+sipeed,lichee-rv-dock |\
+widora,mangopi-mq-pro)
+       ucidef_set_interface_lan "wlan0"
+       ;;
 *)
        ucidef_set_interface_lan 'eth0'
        ;;
index 8dca2fb1cb0ee0f89fdbc9ced4bd9792234bbd15..ea41e65c760e09dc935f40b79a3f7ee0f66a71a2 100644 (file)
@@ -65,7 +65,7 @@ define Device/sipeed_lichee-rv-dock
   DEVICE_MODEL := LicheePi RV (dock)
   DEVICE_DTS := allwinner/sun20i-d1-lichee-rv-dock
   SUPPORTED_DEVICES += lichee_rv_dock
-  DEVICE_PACKAGES += kmod-rtl8723bs
+  DEVICE_PACKAGES += kmod-rtw88-8723ds wpad-basic-mbedtls
   UBOOT := lichee_rv_dock
 endef
 TARGET_DEVICES += sipeed_lichee-rv-dock
@@ -76,7 +76,7 @@ define Device/widora_mangopi-mq-pro
   DEVICE_MODEL := MQ Pro
   DEVICE_DTS := allwinner/sun20i-d1-mangopi-mq-pro
   SUPPORTED_DEVICES += mangopi_mq_pro
-  DEVICE_PACKAGES += kmod-rtl8723bs
+  DEVICE_PACKAGES += kmod-rtw88-8723ds wpad-basic-mbedtls
   UBOOT := mangopi_mq_pro
 endef
 TARGET_DEVICES += widora_mangopi-mq-pro