procps-ng: add new applet sysctl
authorJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 14 Aug 2020 12:06:20 +0000 (14:06 +0200)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 14 Aug 2020 12:21:44 +0000 (14:21 +0200)
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
utils/procps-ng/Makefile

index 7ee7ede9c17fb600d55729b109607cb2539b6030..d6192da4f9fab24835dfaa3b9cc1537a0c514c30 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procps-ng
 PKG_VERSION:=3.3.16
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/procps-ng
@@ -81,6 +81,7 @@ define GenPlugin
 endef
 
 $(foreach a,$(PROCPS_APPLETS),$(eval $(call GenPlugin,procps-ng-$(a),$(a),$(call procps-applets-dir,$(a)))))
+$(eval $(call GenPlugin,procps-ng-sysctl,sysctl,/usr/sbin))
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)" \
@@ -92,6 +93,11 @@ define Package/procps-ng/install
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libprocps.so* $(1)/usr/lib/
 endef
 
+define Package/procps-ng-sysctl/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/sysctl $(1)/usr/sbin
+endef
+
 define BuildPlugin
   define Package/$(1)/install
        $(INSTALL_DIR) $$(1)$(3)
@@ -102,4 +108,5 @@ define BuildPlugin
 endef
 
 $(foreach a,$(PROCPS_APPLETS),$(eval $(call BuildPlugin,procps-ng-$(a),$(a),$(call procps-applets-dir,$(a)))))
+$(eval $(call BuildPackage,procps-ng-sysctl))
 $(eval $(call BuildPackage,procps-ng))