nginx: split DAV_EXT from standard nginx DAV config
authorChristian Marangi <ansuelsmth@gmail.com>
Thu, 20 Apr 2023 05:43:53 +0000 (07:43 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Thu, 20 Apr 2023 05:45:30 +0000 (07:45 +0200)
Split DAV_EXT from standard nginx DAV config as additional WebDAV
methods are provided by an external module.

Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
net/nginx/Config_ssl.in
net/nginx/Makefile

index df54624d3d7fa45a5bc6fe011fe896ba0efa03e6..02dd8094ae4c73e17ce4aa2273a9148fff61c906 100644 (file)
@@ -15,6 +15,14 @@ config NGINX_DAV
                Enable the HTTP and WebDAV methods PUT, DELETE, MKCOL, COPY and MOVE.
        default n
 
+config NGINX_DAV_EXT
+       bool
+       prompt "Enable WebDAV EXT module"
+       select NGINX_DAV
+       help
+               Enable the WebDAV methods PROPFIND, OPTIONS, LOCK, UNLOCK.
+       default n
+
 config NGINX_UBUS
        bool
        prompt "Enable UBUS module"
index aa43193ca539b5af7ed6e3aefca53ad75ef63f97..86a7a212fb6d5d255332ce2caa18881d29f394f7 100644 (file)
@@ -27,6 +27,7 @@ PKG_BUILD_FLAGS:=gc-sections
 
 PKG_CONFIG_DEPENDS := \
        CONFIG_NGINX_DAV \
+       CONFIG_NGINX_DAV_EXT \
        CONFIG_NGINX_FLV \
        CONFIG_NGINX_UBUS \
        CONFIG_NGINX_STUB_STATUS \
@@ -248,7 +249,10 @@ ifneq ($(BUILD_VARIANT),all-module)
     ADDITIONAL_MODULES += --with-http_flv_module
   endif
   ifeq ($(CONFIG_NGINX_DAV),y)
-    ADDITIONAL_MODULES += --with-http_dav_module --add-module=$(PKG_BUILD_DIR)/nginx-dav-ext-module
+    ADDITIONAL_MODULES += --with-http_dav_module
+  endif
+  ifeq ($(CONFIG_NGINX_DAV_EXT),y)
+    ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/nginx-dav-ext-module
   endif
   ifeq ($(CONFIG_NGINX_UBUS),y)
     ADDITIONAL_MODULES += --add-module=$(PKG_BUILD_DIR)/nginx-ubus-module
@@ -297,6 +301,7 @@ else
   CONFIG_NGINX_NAXSI:=y
   CONFIG_NGINX_LUA:=y
   CONFIG_NGINX_DAV:=y
+  CONFIG_NGINX_DAV_EXT:=y
   CONFIG_NGINX_UBUS:=y
   ADDITIONAL_MODULES += --with-ipv6 --with-http_stub_status_module --with-http_flv_module \
        --with-http_dav_module \
@@ -508,7 +513,7 @@ endef
 define Build/Patch
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/nginx,nginx/)
-ifneq "$(or $(CONFIG_NGINX_DAV),$(QUILT))" ""
+ifneq "$(or $(CONFIG_NGINX_DAV_EXT),$(QUILT))" ""
        $(call PatchDir,$(PKG_BUILD_DIR),$(PATCH_DIR)/dav-nginx,dav-nginx/)
 endif
 ifneq "$(or $(CONFIG_NGINX_LUA),$(QUILT))" ""
@@ -562,7 +567,7 @@ ifeq ($(CONFIG_NGINX_TS_MODULE),y)
   $(Prepare/nginx-ts)
 endif
 
-ifneq "$(or $(CONFIG_NGINX_DAV),$(QUILT))" ""
+ifneq "$(or $(CONFIG_NGINX_DAV_EXT),$(QUILT))" ""
   $(eval $(call Download,nginx-dav-ext-module))
   $(Prepare/nginx-dav-ext-module)
 endif