ffmpeg: Add build overrides for some specific CPUs: Octeon, X86 and 24kf.
authorTed Hess <thess@kitschensync.net>
Wed, 15 Aug 2018 12:58:40 +0000 (08:58 -0400)
committerTed Hess <thess@kitschensync.net>
Wed, 15 Aug 2018 13:01:39 +0000 (09:01 -0400)
Octeon: Rename octeonplus to oction+
MIPS 24kf: Inline ASM fails to build (unknown reason)
X86: Configure finds NASM and assumes YASM if name explictly set (wrong switches)

Signed-off-by: Ted Hess <thess@kitschensync.net>
multimedia/ffmpeg/Makefile

index 0c4c08052c444cacc13e90793b1c12a792f19b4b..9aaf14287d60f19bacaa3ec3eaaccc2931ce0dce 100644 (file)
@@ -374,6 +374,8 @@ endef
 
 # Strip off FPU notation
 REAL_CPU_TYPE:=$(firstword $(subst +, ,$(CONFIG_CPU_TYPE)))
+# Fixup cpu types recogized by ffmpeg configure
+REAL_CPU_TYPE:=$(subst octeonplus,octeon+,$(REAL_CPU_TYPE))
 
 FFMPEG_CONFIGURE:= \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) $(FPIC)" \
@@ -422,6 +424,10 @@ FFMPEG_CONFIGURE+= \
 else ifneq ($(findstring powerpc,$(CONFIG_ARCH)),)
 FFMPEG_CONFIGURE+= \
        --disable-altivec
+# libavcode/mips/aacdec_mips.c build problem
+else ifneq ($(findstring 24kf,$(CONFIG_CPU_TYPE)),)
+FFMPEG_CONFIGURE+= \
+       --disable-inline-asm
 endif
 
 # selectively disable optimizations according to arch/cpu type
@@ -448,7 +454,9 @@ endif
 
 ifneq ($(CONFIG_TARGET_x86),)
 ifeq ($(CONFIG_NASM),y)
-  FFMPEG_CONFIGURE += --yasmexe=nasm
+  # Set yasmexe to anything but YASM/NASM (ffmpeg configure will then find NASM correctly)
+  # Newer ffmpeg packages will use --enable-x86asm (with NASM default)
+  FFMPEG_CONFIGURE += --yasmexe=xyzzy
 else
   FFMPEG_CONFIGURE += --disable-yasm
 endif