asu: Change Python 2 dependencies to Python 3
authorJeffery To <jeffery.to@gmail.com>
Fri, 10 Jan 2020 12:40:50 +0000 (20:40 +0800)
committerJeffery To <jeffery.to@gmail.com>
Fri, 10 Jan 2020 12:58:23 +0000 (20:58 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
devel/asu/Makefile
devel/asu/files/asu.init

index 9485ed9d7cc12e638ca644c03eea7baf42df1d1a..a6f0a8ef5cf1215ef4c1aa12ac6325b8b2fa3714 100644 (file)
@@ -23,7 +23,7 @@ IMAGEBUILDER_DEPENDS:= \
     @x86_64 +bash +bzip2 +coreutils +coreutils-stat +diffutils +file \
     +gawk +gcc +getopt +git +git-http +libncurses +make +patch +perl \
     +perlbase-attributes +perlbase-findbin +perlbase-getopt \
-    +perlbase-thread +python-light +tar +unzip +wget +xz +xzdiff \
+    +perlbase-thread +python3-light +tar +unzip +wget +xz +xzdiff \
     +xzgrep +xzless +xz-utils +zlib-dev
 
 define Package/asu
@@ -34,7 +34,7 @@ define Package/asu
     URL:=http://github.com/aparcar/gsoc17-attended-sysupgrade/
     DEPENDS:=$(IMAGEBUILDER_DEPENDS) +pgsql-server +psqlodbcw \
              +python3-ctypes +python3-distutils +python3-flask \
-             +gunicorn +python3-openssl +python3-pyodbc +python3-yaml \
+             +gunicorn3 +python3-openssl +python3-pyodbc +python3-yaml \
              +libustream-mbedtls +ca-certificates +gnupg
     USERID:=asu:asu
     VARIANT:=python3
index 069c0e716eda70ce4568e3fda6fa4914695ac769..d12221b898e925c54cbce6d10e92cb6676579005 100644 (file)
@@ -28,7 +28,7 @@ start_service() {
     procd_open_instance asu_main
     procd_set_param user asu
     procd_set_param group asu
-    procd_set_param command gunicorn asu:app
+    procd_set_param command gunicorn3 asu:app
     procd_close_instance
 
     procd_open_instance main_worker