grep: update to 3.7
authorMichal Vasilek <michal.vasilek@nic.cz>
Tue, 24 Aug 2021 13:30:25 +0000 (15:30 +0200)
committerMichal Vasilek <michal.vasilek@nic.cz>
Tue, 24 Aug 2021 13:40:28 +0000 (15:40 +0200)
Signed-off-by: Michal Vasilek <michal.vasilek@nic.cz>
utils/grep/Makefile
utils/grep/patches/ppc-musl.patch [new file with mode: 0644]

index 38cb1ea88050e5363dfb23d2026bb15bda0db0f3..2ec599095ecc26a4313a5165ce282ddf4810beef 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=grep
-PKG_VERSION:=3.6
+PKG_VERSION:=3.7
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/grep
-PKG_HASH:=667e15e8afe189e93f9f21a7cd3a7b3f776202f417330b248c2ad4f997d9373e
+PKG_HASH:=5c10da312460aec721984d5d83246d24520ec438dd48d7ab5a05dbc0d6d6823c
 
 PKG_MAINTAINER:=Julen Landa Alustiza <julen@zokormazo.info>
 PKG_LICENSE:=GPL-3.0-or-later
diff --git a/utils/grep/patches/ppc-musl.patch b/utils/grep/patches/ppc-musl.patch
new file mode 100644 (file)
index 0000000..45c79eb
--- /dev/null
@@ -0,0 +1,15 @@
+https://github.com/void-linux/void-packages/commit/0d9556b8593d6e67027fb1c83d176b7f899547e5
+--- a/lib/sigsegv.c
++++ b/lib/sigsegv.c
+@@ -221,8 +221,10 @@ int libsigsegv_version = LIBSIGSEGV_VERS
+ /* both should be equivalent */
+ #   if 0
+ #    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.regs->gpr[1]
+-#   else
++#   elif defined(__GLIBC__)
+ #    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.uc_regs->gregs[1]
++#   else
++#    define SIGSEGV_FAULT_STACKPOINTER  ((ucontext_t *) ucp)->uc_mcontext.gregs[1]
+ #   endif
+ #  endif