django-webpack-loader: update packaging format + add python3 variant
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 3 Jul 2019 09:05:05 +0000 (12:05 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 11 Jul 2019 12:16:36 +0000 (15:16 +0300)
This change also updates the maintainer email to cotequeiroz@gmail.com, as
requested on a different change.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/django-webpack-loader/Makefile
net/seafile-seahub/Makefile

index fe1d88e8b42605a87603e23bff32b217141c25b8..5186ed946cf8d87bb10f46cc9f312b46e580a27e 100644 (file)
@@ -7,33 +7,62 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=django-webpack-loader
 PKG_VERSION:=0.6.0
-PKG_RELEASE:=4
-
-PKG_MAINTAINER:=Eneas U de Queiroz <cote2004-github@yahoo.com>
-PKG_LICENSE:=MIT
-PKG_LICENSE_FILES:=LICENSE
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/d/${PKG_NAME}
 PKG_HASH:=60bab6b9a037a5346fad12d2a70a6bc046afb33154cf75ed640b93d3ebd5f520
 
+PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-$(PKG_NAME)-$(PKG_VERSION)
+
 include $(INCLUDE_DIR)/package.mk
 include ../python-package.mk
+include ../python3-package.mk
+
+PKG_UNPACK:=$(HOST_TAR) -C $(PKG_BUILD_DIR) --strip-components=1 -xzf $(DL_DIR)/$(PKG_SOURCE)
 
-define Package/django-webpack-loader
+define Package/$(PKG_NAME)/Default
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=Transparently use webpack in django
   URL:=https://github.com/owais/django-webpack-loader
-  DEPENDS:=+python +python-django
+endef
+
+define Package/python-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python-$(PKG_NAME):python \
+       +PACKAGE_python-$(PKG_NAME):python-django
   VARIANT:=python
 endef
 
-define Package/django-webpack-loader/description
+define Package/python-$(PKG_NAME)/description
   Use webpack to generate your static bundles without django’s staticfiles or opaque wrappers.
 endef
 
-$(eval $(call PyPackage,django-webpack-loader))
-$(eval $(call BuildPackage,django-webpack-loader))
-$(eval $(call BuildPackage,django-webpack-loader-src))
+define Package/python3-$(PKG_NAME)
+$(call Package/$(PKG_NAME)/Default)
+  DEPENDS:= \
+       +PACKAGE_python3-$(PKG_NAME):python3 \
+       +PACKAGE_python3-$(PKG_NAME):python3-django
+  VARIANT:=python3
+endef
+
+define Package/python3-$(PKG_NAME)/description
+$(call define Package/python-$(PKG_NAME)/description)
+.
+(Variant for Python3)
+endef
+
+$(eval $(call PyPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)))
+$(eval $(call BuildPackage,python-$(PKG_NAME)-src))
+
+$(eval $(call Py3Package,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)))
+$(eval $(call BuildPackage,python3-$(PKG_NAME)-src))
index 41d36e16419de2daf7642a6f71507a2de3f83781..ef8782a2334d253fe5ca28b653e15556a63a8676 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=seafile-seahub
 PKG_VERSION:=6.3.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/haiwen/seahub/tar.gz/v$(PKG_VERSION)-server?
@@ -30,7 +30,7 @@ SEAFILE_PYTHON_DEPENDS:= \
        simplejson chardet dateutil mysql pytz qrcode requests requests-oauthlib \
        django django-constance django-appconf django-compressor django-formtools \
        django-jsonfield django-picklefield django-postoffice django-restframework \
-       pillow django-simple-captcha django-statici18n
+       pillow django-simple-captcha django-statici18n django-webpack-loader
 
 define Package/seafile-seahub
   SECTION:=net
@@ -38,7 +38,6 @@ define Package/seafile-seahub
   TITLE:=Seafile server - seahub component
   URL:=https://seafile.com/
   DEPENDS:=+python \
-       +django-webpack-loader \
        +python-flup +gunicorn +openpyxl \
        $(foreach dep,$(SEAFILE_PYTHON_DEPENDS),+python-$(dep))
 endef