yara: add dotnet module
authorAshkan Jazayeri <ashkan@jazayeri.net>
Tue, 5 Jun 2018 18:01:14 +0000 (22:31 +0430)
committerAshkan Jazayeri <ashkan@jazayeri.net>
Tue, 5 Jun 2018 18:01:14 +0000 (22:31 +0430)
Dotnet module added as a compile time option.
The dotnet module allows you to create more fine-grained rules
for .NET files by using attributes and features of the .NET file format.
http://yara.readthedocs.io/en/latest/modules/dotnet.html

Signed-off-by: Ashkan Jazayeri <ashkan@jazayeri.net>
utils/yara/Config.in
utils/yara/Makefile

index 76e83db6bc53f7cf56f0017d77228c90b7f98f47..328ce4c94359d858140618aa6a419b94d59ce259 100644 (file)
@@ -12,5 +12,12 @@ if PACKAGE_yara
                default n
                help
                  Create rules based on behavioral info generated by a Cuckoo sandbox
+
+       config YARA_module_dotnet
+               bool "Dotnet module"
+               default n
+               help
+                 The dotnet module allows you to create more fine-grained rules
+                 for .NET files by using attributes and features of the .NET file format
 endif
 
index 709d14728c54583f4a7460757922a7ff2b7ca622..1e908d218fae7bad8492f862c97a504f269a55a4 100644 (file)
@@ -41,7 +41,7 @@ define Package/yara/description
 endef
 
 CONFIGURE_ARGS += \
-       --disable-dotnet \
+       $(if $(CONFIG_YARA_module_dotnet),--enable,--disable)-dotnet \
        $(if $(CONFIG_YARA_module_magic),--enable,--disable)-magic \
        $(if $(CONFIG_YARA_module_cuckoo),--enable,--disable)-cuckoo