wifitoggle: merge r35415
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 31 Jan 2013 12:48:55 +0000 (12:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 31 Jan 2013 12:48:55 +0000 (12:48 +0000)
SVN-Revision: 35416

utils/wifitoggle/Makefile
utils/wifitoggle/files/wifitoggle.hotplug

index abf0fc8653261ec4069c48b29cb28605b84d7c3f..b3154b69d2c1f56c567fe26f8762690fcaa407b0 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2010-2012 OpenWrt.org
+# Copyright (C) 2010-2013 OpenWrt.org
 # Copyright (C) 2010 segal.di.ubi.pt 
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=wifitoggle
 PKG_VERSION:=1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 include $(INCLUDE_DIR)/package.mk
 
index fdeeb742f46f361d20443a506be2a41a7f6bf78e..174693eceda551e51f61a29ba2bbbc8e1e09f1e3 100755 (executable)
@@ -157,11 +157,8 @@ load_wifitoggle() {
                if [ "$disabled" = "1" ] 
                then
                        enable $1
-               elif [ "$disabled" = "0" ]
-               then
-                       disable
                else
-                       logger -p user.err -t "wifitoggle" "device($device) not recognized"
+                       disable
                fi
         }
 }