unixodbc: Fix LIB_PREFIX in host build
authorEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 11:43:36 +0000 (09:43 -0200)
committerEneas U de Queiroz <cote2004-github@yahoo.com>
Thu, 6 Dec 2018 12:30:17 +0000 (10:30 -0200)
When copying config.h from PKG_BUILD_DIR to HOST_BUILD_DIR, LIB_PREFIX
is set to /usr/lib.  Then when odbc_config is run, it reports /usr/lib
as the --lib-dir, and in --libs as well, and dependent packages may
fail.  Set it to $(STAGING_DIR)/usr/lib to make it right.

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
libs/unixodbc/Makefile

index 966848ac3cb89ee462dc36c7d94030e24138a6a5..21a8af1802ba67ebd66599b8f184c6b193777bb8 100644 (file)
@@ -132,6 +132,7 @@ endef
 define Host/Configure
        $(call Host/Configure/Default)
        cp $(PKG_BUILD_DIR)/config.h $(HOST_BUILD_DIR)
+       sed -i -e 's!\(LIB_PREFIX \).*$$$$!\1"$(STAGING_DIR)/usr/lib"!' $(HOST_BUILD_DIR)/config.h
        cp $(PKG_BUILD_DIR)/unixodbc_conf.h $(HOST_BUILD_DIR)
 endef