python-lxml: bump to version 5.3.0
authorAlexandru Ardelean <alex@shruggie.ro>
Fri, 23 Aug 2024 13:15:42 +0000 (16:15 +0300)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Wed, 25 Dec 2024 19:33:52 +0000 (21:33 +0200)
Signed-off-by: Alexandru Ardelean <alex@shruggie.ro>
lang/python/python-lxml/Makefile
lang/python/python-lxml/patches/001-downgrade-cython-requirement.patch [new file with mode: 0644]
lang/python/python-lxml/test.sh

index d517cd8401511ac3bcf639db56a26a1f98f28fcc..4253d92367bfd661f089c63bf0d455f11f6f5a75 100644 (file)
@@ -8,11 +8,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-lxml
-PKG_VERSION:=5.2.2
+PKG_VERSION:=5.3.0
 PKG_RELEASE:=1
 
 PYPI_NAME:=lxml
-PKG_HASH:=bb2dc4898180bea79863d5487e5f9c7c34297414bad54bcd0f0852aee9cfdb87
+PKG_HASH:=4e109ca30d1edec1ac60cdbe341905dc3b8f55b16855e03a54aaf59e51ec8c6f
 
 PKG_LICENSE:=BSD-3-Clause
 PKG_LICENSE_FILES:=LICENSES.txt
diff --git a/lang/python/python-lxml/patches/001-downgrade-cython-requirement.patch b/lang/python/python-lxml/patches/001-downgrade-cython-requirement.patch
new file mode 100644 (file)
index 0000000..f73f46c
--- /dev/null
@@ -0,0 +1,9 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,5 +1,5 @@
+ [build-system]
+-requires = ["Cython>=3.0.11", "setuptools", "wheel"]
++requires = ["Cython>=3.0.10", "setuptools", "wheel"]
+ [tool.cibuildwheel]
+ build-verbosity = 2
index 6ea15a0e8e4d327133d7da74d437e09c07e735ac..e175d9239cd64cbaae8427bf7aac213c0f2d0c8b 100644 (file)
@@ -1,7 +1,5 @@
 #!/bin/sh
 
-[ "$1" = "python3-lxml" ] || exit 0
-
 EXP_VER="$2"
 
 python3 - << EOF