coreutils: update to 9.0
authorJohn Audia <graysky@archlinux.us>
Sun, 20 Feb 2022 14:20:06 +0000 (09:20 -0500)
committerRosen Penev <rosenp@gmail.com>
Thu, 24 Feb 2022 01:10:08 +0000 (17:10 -0800)
Removed unneed patch:
  002-ls-restore-831-behavior-on-removed-directories.patch

After updating ran `make package/coreutils/refresh` from $BUILDROOT to clean
dirty patches.

Build system: x86_64
Build-tested: bcm2711/RPi4B
Run-tested: bcm2711/RPi4B

Signed-off-by: John Audia <graysky@archlinux.us>
utils/coreutils/Makefile
utils/coreutils/patches/001-no_docs_man_tests.patch
utils/coreutils/patches/002-ls-restore-831-behavior-on-removed-directories.patch [deleted file]

index 157a2496f1115bc449d430632a431ddee295b2ea..b71faf4ca8167f4ff437186562b67f9b7fe00ca0 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=coreutils
-PKG_VERSION:=8.32
-PKG_RELEASE:=6
+PKG_VERSION:=9.0
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/coreutils
-PKG_HASH:=4458d8de7849df44ccab15e16b1548b285224dbba5f08fac070c1c0e0bcc4cfa
+PKG_HASH:=ce30acdf4a41bc5bb30dd955e9eaa75fa216b4e3deb08889ed32433c7b3b97ce
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=GPL-3.0-or-later
index dde75778d1b2bde66c618579d1f859f0a81d1baf..be4c28ca595ca914de0c31c8ec6fe64b80097a5f 100644 (file)
@@ -18,7 +18,7 @@
 -include $(top_srcdir)/tests/local.mk
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -3156,11 +3156,7 @@ RECURSIVE_TARGETS = all-recursive check-
+@@ -3232,11 +3232,7 @@ RECURSIVE_TARGETS = all-recursive check-
        install-ps-recursive install-recursive installcheck-recursive \
        installdirs-recursive pdf-recursive ps-recursive \
        tags-recursive uninstall-recursive
  am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
  am__vpath_adj = case $$p in \
      $(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
-@@ -3411,11 +3407,11 @@ am__DIST_COMMON = $(doc_coreutils_TEXINF
+@@ -3486,10 +3482,10 @@ am__DIST_COMMON = $(doc_coreutils_TEXINF
        $(top_srcdir)/build-aux/missing \
        $(top_srcdir)/build-aux/test-driver \
        $(top_srcdir)/build-aux/texinfo.tex \
 -      $(top_srcdir)/build-aux/ylwrap $(top_srcdir)/doc/local.mk \
-+      $(top_srcdir)/build-aux/ylwrap \
-       $(top_srcdir)/lib/alloca.c $(top_srcdir)/lib/config.hin \
+-      $(top_srcdir)/lib/alloca.c $(top_srcdir)/lib/config.hin \
 -      $(top_srcdir)/lib/local.mk $(top_srcdir)/man/local.mk \
+-      $(top_srcdir)/src/local.mk $(top_srcdir)/src/single-binary.mk \
++      $(top_srcdir)/build-aux/ylwrap \
++      $(top_srcdir)/lib/alloca.c \
 +      $(top_srcdir)/lib/local.mk \
-       $(top_srcdir)/src/local.mk $(top_srcdir)/src/single-binary.mk \
--      $(top_srcdir)/tests/local.mk ABOUT-NLS AUTHORS COPYING \
-+      ABOUT-NLS AUTHORS COPYING \
-       ChangeLog INSTALL NEWS README THANKS TODO build-aux/ar-lib \
-       build-aux/compile build-aux/config.guess \
-       build-aux/config.rpath build-aux/config.sub build-aux/depcomp \
-@@ -3516,7 +3512,7 @@ EOVERFLOW_HIDDEN = @EOVERFLOW_HIDDEN@
- EOVERFLOW_VALUE = @EOVERFLOW_VALUE@
++      $(top_srcdir)/src/local.mk \
+       $(top_srcdir)/tests/local.mk ABOUT-NLS AUTHORS COPYING \
+       ChangeLog INSTALL NEWS README THANKS TODO build-aux/compile \
+       build-aux/config.guess build-aux/config.rpath \
+@@ -3596,7 +3592,7 @@ EOVERFLOW_VALUE = @EOVERFLOW_VALUE@
  ERRNO_H = @ERRNO_H@
+ ETAGS = @ETAGS@
  EXEEXT = @EXEEXT@
 -EXTRA_MANS = @EXTRA_MANS@
 +EXTRA_MANS =
  FLOAT_H = @FLOAT_H@
  FNMATCH_H = @FNMATCH_H@
  GETADDRINFO_LIB = @GETADDRINFO_LIB@
-@@ -4961,7 +4957,7 @@ libexecdir = @libexecdir@
+@@ -5158,7 +5154,7 @@ libexecdir = @libexecdir@
  lispdir = @lispdir@
  localedir = @localedir@
  localstatedir = @localstatedir@
@@ -64,7 +64,7 @@
  mandir = @mandir@
  mkdir_p = @mkdir_p@
  oldincludedir = @oldincludedir@
-@@ -4984,7 +4980,7 @@ top_build_prefix = @top_build_prefix@
+@@ -5181,7 +5177,7 @@ top_build_prefix = @top_build_prefix@
  top_builddir = @top_builddir@
  top_srcdir = @top_srcdir@
  ALL_RECURSIVE_TARGETS = distcheck-hook check-root
@@ -73,7 +73,7 @@
  
  #if GNU_MAKE
  #     [nicer features that work only with GNU Make]
-@@ -7030,7 +7026,7 @@ all: $(BUILT_SOURCES)
+@@ -7389,7 +7385,7 @@ all: $(BUILT_SOURCES)
  .SUFFIXES: .1 .c .dvi .log .o .obj .pl .pl$(EXEEXT) .ps .sh .sh$(EXEEXT) .trs .x .xpl .xpl$(EXEEXT) .y
  am--refresh: Makefile
        @:
@@ -82,7 +82,7 @@
        @for dep in $?; do \
          case '$(am__configure_deps)' in \
            *$$dep*) \
-@@ -7052,7 +7048,7 @@ Makefile: $(srcdir)/Makefile.in $(top_bu
+@@ -7411,7 +7407,7 @@ Makefile: $(srcdir)/Makefile.in $(top_bu
            echo ' cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__maybe_remake_depfiles)'; \
            cd $(top_builddir) && $(SHELL) ./config.status $@ $(am__maybe_remake_depfiles);; \
        esac;
diff --git a/utils/coreutils/patches/002-ls-restore-831-behavior-on-removed-directories.patch b/utils/coreutils/patches/002-ls-restore-831-behavior-on-removed-directories.patch
deleted file mode 100644 (file)
index b297f37..0000000
+++ /dev/null
@@ -1,108 +0,0 @@
-From 10fcb97bd728f09d4a027eddf8ad2900f0819b0a Mon Sep 17 00:00:00 2001
-From: Paul Eggert <eggert@cs.ucla.edu>
-Date: Thu, 5 Mar 2020 17:25:29 -0800
-Subject: ls: restore 8.31 behavior on removed directories
-
-* NEWS: Mention this.
-* src/ls.c: Do not include <sys/sycall.h>
-(print_dir): Don't worry about whether the directory is removed.
-* tests/ls/removed-directory.sh: Adjust to match new (i.e., old)
-behavior.
----
- NEWS                          |  6 ++++++
- src/ls.c                      | 22 ----------------------
- tests/ls/removed-directory.sh | 10 ++--------
- 3 files changed, 8 insertions(+), 30 deletions(-)
-
---- a/NEWS
-+++ b/NEWS
-@@ -97,6 +97,12 @@ GNU coreutils NEWS
-   gzip-compressed tarballs are distributed once again
-+** Changes in behavior
-+
-+  On GNU/Linux systems, ls no longer issues an error message on
-+  directory merely because it was removed.  This reverts a change
-+  that was made in release 8.32.
-+
- * Noteworthy changes in release 8.31 (2019-03-10) [stable]
---- a/src/ls.c
-+++ b/src/ls.c
-@@ -49,10 +49,6 @@
- # include <sys/ptem.h>
- #endif
--#ifdef __linux__
--# include <sys/syscall.h>
--#endif
--
- #include <stdio.h>
- #include <assert.h>
- #include <setjmp.h>
-@@ -2896,7 +2892,6 @@ print_dir (char const *name, char const
-   struct dirent *next;
-   uintmax_t total_blocks = 0;
-   static bool first = true;
--  bool found_any_entries = false;
-   errno = 0;
-   dirp = opendir (name);
-@@ -2972,7 +2967,6 @@ print_dir (char const *name, char const
-       next = readdir (dirp);
-       if (next)
-         {
--          found_any_entries = true;
-           if (! file_ignored (next->d_name))
-             {
-               enum filetype type = unknown;
-@@ -3018,22 +3012,6 @@ print_dir (char const *name, char const
-           if (errno != EOVERFLOW)
-             break;
-         }
--#ifdef __linux__
--      else if (! found_any_entries)
--        {
--          /* If readdir finds no directory entries at all, not even "." or
--             "..", then double check that the directory exists.  */
--          if (syscall (SYS_getdents, dirfd (dirp), NULL, 0) == -1
--              && errno != EINVAL)
--            {
--              /* We exclude EINVAL as that pertains to buffer handling,
--                 and we've passed NULL as the buffer for simplicity.
--                 ENOENT is returned if appropriate before buffer handling.  */
--              file_failure (command_line_arg, _("reading directory %s"), name);
--            }
--          break;
--        }
--#endif
-       else
-         break;
---- a/tests/ls/removed-directory.sh
-+++ b/tests/ls/removed-directory.sh
-@@ -26,20 +26,14 @@ case $host_triplet in
-   *) skip_ 'non linux kernel' ;;
- esac
--LS_FAILURE=2
--
--cat <<\EOF >exp-err || framework_failure_
--ls: reading directory '.': No such file or directory
--EOF
--
- cwd=$(pwd)
- mkdir d || framework_failure_
- cd d || framework_failure_
- rmdir ../d || framework_failure_
--returns_ $LS_FAILURE ls >../out 2>../err || fail=1
-+ls >../out 2>../err || fail=1
- cd "$cwd" || framework_failure_
- compare /dev/null out || fail=1
--compare exp-err err || fail=1
-+compare /dev/null err || fail=1
- Exit $fail