twisted: update to 18.4.0, refresh patches
authorJeffery To <jeffery.to@gmail.com>
Sun, 24 Jun 2018 20:00:16 +0000 (04:00 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 25 Jun 2018 20:58:14 +0000 (04:58 +0800)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/twisted/Makefile
lang/python/twisted/patches/001-omit-tkconch-patch [deleted file]
lang/python/twisted/patches/001-omit-tkconch.patch [new file with mode: 0644]
lang/python/twisted/patches/002-omit-tests.patch

index 36c1a779df935d8bc0a568df435de4fe29717680..35b78172bf1192facee481a7dee4fc82f7370228 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=twisted
-PKG_VERSION:=17.9.0
+PKG_VERSION:=18.4.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=Twisted-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/T/Twisted
-PKG_HASH:=0da1a7e35d5fcae37bc9c7978970b5feb3bc82822155b8654ec63925c05af75c
+PKG_HASH:=a4cc164a781859c74de47f17f0e85f4bce8a3321a9d0892c015c8f80c4158ad9
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-twisted-$(PKG_VERSION)
 PKG_BUILD_DEPENDS:=USE_MUSL:librpc
diff --git a/lang/python/twisted/patches/001-omit-tkconch-patch b/lang/python/twisted/patches/001-omit-tkconch-patch
deleted file mode 100644 (file)
index 05ad4c8..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-diff --git a/src/twisted/python/_setup.py b/src/twisted/python/_setup.py
-index 3b5f69d4b..c69c5d13c 100644
---- a/src/twisted/python/_setup.py
-+++ b/src/twisted/python/_setup.py
-@@ -142,7 +142,6 @@ _CONSOLE_SCRIPTS = [
-     "cftp = twisted.conch.scripts.cftp:run",
-     "conch = twisted.conch.scripts.conch:run",
-     "pyhtmlizer = twisted.scripts.htmlizer:run",
--    "tkconch = twisted.conch.scripts.tkconch:run",
-     "trial = twisted.scripts.trial:run",
-     "twist = twisted.application.twist._twist:Twist.main",
-     "twistd = twisted.scripts.twistd:run",
-diff --git a/src/twisted/python/twisted-completion.zsh b/src/twisted/python/twisted-completion.zsh
-index 4d97aa5d3..9a8d4d82e 100644
---- a/src/twisted/python/twisted-completion.zsh
-+++ b/src/twisted/python/twisted-completion.zsh
-@@ -1,4 +1,4 @@
--#compdef twistd trial conch cftp ckeygen pyhtmlizer tkconch
-+#compdef twistd trial conch cftp ckeygen pyhtmlizer
- #
- # This is the ZSH completion file for Twisted commands. It calls the current
- # command-line with the special "--_shell-completion" option which is handled
diff --git a/lang/python/twisted/patches/001-omit-tkconch.patch b/lang/python/twisted/patches/001-omit-tkconch.patch
new file mode 100644 (file)
index 0000000..2e5e401
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/src/twisted/python/_setup.py
++++ b/src/twisted/python/_setup.py
+@@ -143,7 +143,6 @@ _CONSOLE_SCRIPTS = [
+     "conch = twisted.conch.scripts.conch:run",
+     "mailmail = twisted.mail.scripts.mailmail:run",
+     "pyhtmlizer = twisted.scripts.htmlizer:run",
+-    "tkconch = twisted.conch.scripts.tkconch:run",
+     "trial = twisted.scripts.trial:run",
+     "twist = twisted.application.twist._twist:Twist.main",
+     "twistd = twisted.scripts.twistd:run",
+--- a/src/twisted/python/twisted-completion.zsh
++++ b/src/twisted/python/twisted-completion.zsh
+@@ -1,4 +1,4 @@
+-#compdef twist twistd trial conch cftp ckeygen pyhtmlizer tkconch
++#compdef twist twistd trial conch cftp ckeygen pyhtmlizer
+ #
+ # This is the ZSH completion file for Twisted commands. It calls the current
+ # command-line with the special "--_shell-completion" option which is handled
index 46496201076b8f6dd60ede76092425d1514b6c1c..7e8109807771e7bad45f537ca9ab8a2d9875427b 100644 (file)
@@ -1,21 +1,19 @@
-diff --git a/src/twisted/python/_setup.py b/src/twisted/python/_setup.py
-index 3b5f69d4b..2dca47aa5 100644
 --- a/src/twisted/python/_setup.py
 +++ b/src/twisted/python/_setup.py
-@@ -175,11 +175,6 @@ class ConditionalExtension(Extension, object):
+@@ -169,11 +169,6 @@ class ConditionalExtension(Extension, ob
  # The C extensions used for Twisted.
  _EXTENSIONS = [
--    ConditionalExtension(
+     ConditionalExtension(
 -        "twisted.test.raiser",
 -        sources=["src/twisted/test/raiser.c"],
 -        condition=lambda _: _isCPython),
 -
-     ConditionalExtension(
+-    ConditionalExtension(
          "twisted.internet.iocpreactor.iocpsupport",
          sources=[
-@@ -232,7 +227,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
-     requirements.append("hyperlink >= 17.1.1")
+             "src/twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",
+@@ -240,7 +235,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
+     ]
  
      arguments.update(dict(
 -        packages=find_packages("src"),
@@ -23,7 +21,7 @@ index 3b5f69d4b..2dca47aa5 100644
          use_incremental=True,
          setup_requires=["incremental >= 16.10.1"],
          install_requires=requirements,
-@@ -241,6 +236,7 @@ def getSetupArgs(extensions=_EXTENSIONS):
+@@ -249,6 +244,7 @@ def getSetupArgs(extensions=_EXTENSIONS)
          },
          cmdclass=command_classes,
          include_package_data=True,