python-six: remove python2 variant of host install
authorYousong Zhou <yszhou4tech@gmail.com>
Fri, 26 Apr 2019 02:23:35 +0000 (02:23 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Fri, 26 Apr 2019 13:03:37 +0000 (21:03 +0800)
The python2 host variant is not needed anymore as openvswitch has now
switch to using python3 for building

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
lang/python/python-six/Makefile

index d667b9b49465174b0d557d0fefcc1d3f7b45e3e1..b58c7b84cda9676e7bd827933ee67f0c42649421 100644 (file)
@@ -21,7 +21,7 @@ PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENSE
 PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>, Alexandru Ardelean <ardeleanalex@gmail.com>
 
-HOST_BUILD_DEPENDS:=python/host python3/host
+HOST_BUILD_DEPENDS:=python3/host
 
 include $(INCLUDE_DIR)/host-build.mk
 include $(INCLUDE_DIR)/package.mk
@@ -65,7 +65,6 @@ $(call Package/python-six/description)
 endef
 
 define Host/Compile
-       $(call Build/Compile/HostPyMod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
        $(call Build/Compile/HostPy3Mod,,install --prefix="" --root="$(STAGING_DIR_HOSTPKG)")
 endef