xray-core: remove PROVIDES
authorTianling Shen <cnsztl@immortalwrt.org>
Tue, 27 Apr 2021 11:42:41 +0000 (19:42 +0800)
committerTianling Shen <cnsztl@immortalwrt.org>
Tue, 27 Apr 2021 12:34:18 +0000 (20:34 +0800)
Xray now is no longer planning to keep compatibility with original
v2ray. Remove PROVIDES before it is totally broken.

Signed-off-by: Tianling Shen <cnsztl@immortalwrt.org>
net/xray-core/Makefile
net/xray-core/files/config.json.example

index 1264dc9a7f5213c74c577ff73d127154bd3d060f..0db91efa3df989a43568374dc1dbec4f90466ba7 100644 (file)
@@ -37,7 +37,6 @@ endef
 define Package/xray-core
   $(call Package/xray/template)
   DEPENDS:=$(GO_ARCH_DEPENDS) +ca-bundle
-  PROVIDES:=v2ray-core
 endef
 
 define Package/xray-example
@@ -55,7 +54,7 @@ define Package/xray-geodata
 endef
 
 define Package/xray/description
-  Xray, Penetrates Everything. Also the best v2ray-core, with XTLS support. Fully compatible configuration.
+  Xray, Penetrates Everything. It helps you to build your own computer network.
   It secures your network connections and thus protects your privacy.
 endef
 
@@ -112,7 +111,6 @@ define Package/xray-core/install
        $(call GoPackage/Package/Install/Bin,$(PKG_INSTALL_DIR))
        $(INSTALL_DIR) $(1)/usr/bin/
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/main $(1)/usr/bin/xray
-       $(LN) xray $(1)/usr/bin/v2ray
 
        $(INSTALL_DIR) $(1)/etc/xray/
        $(INSTALL_CONF) $(CURDIR)/files/config.json.example $(1)/etc/xray/
index 52597f5878381f17ded5e943dce578ab3baef12f..710bb1bec260d9868a27e8613f2e7cff5a5b920b 100644 (file)
@@ -1,6 +1,6 @@
 // Config file of Xray. This file follows standard JSON format, with comments support.
 // Uncomment entries below to satisfy your needs. Also read our manual for more detail at
-// https://www.v2fly.org/en_US/config/overview.html and https://xray.sh/en/config/
+// https://xtls.github.io/en/config/
 {
   "log": {
     // By default, Xray writes access log to stdout.