python-certifi: add hostbuild
authorAustin Lane <vidplace7@gmail.com>
Thu, 5 Dec 2024 05:41:21 +0000 (00:41 -0500)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 9 Dec 2024 08:59:17 +0000 (10:59 +0200)
Signed-off-by: Austin Lane <vidplace7@gmail.com>
lang/python/python-certifi/Makefile

index f31d34d24398527e3ee325d8ebcae59a4bc970f7..4d5b02d039ebc52ee0ee3dd2fc013d7d0d739073 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-certifi
 PKG_VERSION:=2024.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Eneas U de Queiroz <cotequeiroz@gmail.com>
 PKG_LICENSE:=MPL-2.0
@@ -16,9 +16,13 @@ PKG_LICENSE_FILES:=LICENSE
 PYPI_NAME:=certifi
 PKG_HASH:=0569859f95fc761b18b45ef421b1290a0f65f147e92a1e5eb3e635f9a5e4e66f
 
+HOST_BUILD_DEPENDS:=python3/host python-build/host python-installer/host python-wheel/host
+
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
 include ../python3-package.mk
+include ../python3-host-build.mk
 
 define Package/python3-certifi
   SUBMENU:=Python
@@ -38,3 +42,4 @@ endef
 $(eval $(call Py3Package,python3-certifi))
 $(eval $(call BuildPackage,python3-certifi))
 $(eval $(call BuildPackage,python3-certifi-src))
+$(eval $(call HostBuild))