linknx: fix compilation without sys/cdefs
authorRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 20:40:49 +0000 (13:40 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 10 Aug 2020 22:23:59 +0000 (15:23 -0700)
sys/cdefs.h is not included with musl. It's also deprecated.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/linknx/Makefile
net/linknx/patches/010-cdefs.patch [new file with mode: 0644]

index f097057b3da0b4215e4a4c5744e3fa4a4abbb522..801dd0c7c1dffe5c3ece9b580d3dae7b4f61e5e4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=linknx
 PKG_VERSION:=0.0.1.38
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-${PKG_VERSION}.tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/linknx/linknx/tar.gz/$(PKG_VERSION)?
diff --git a/net/linknx/patches/010-cdefs.patch b/net/linknx/patches/010-cdefs.patch
new file mode 100644 (file)
index 0000000..971a9c7
--- /dev/null
@@ -0,0 +1,26 @@
+--- a/include/eibclient.h
++++ b/include/eibclient.h
+@@ -27,11 +27,12 @@
+ #ifndef EIBCLIENT_H
+ #define EIBCLIENT_H
+-#include "sys/cdefs.h"
+ #include "stdint.h"
+ #include <pthsem.h>
+-__BEGIN_DECLS;
++#ifdef __cplusplus
++extern "C" {
++#endif
+ #include "eibloadresult.h"
+@@ -705,5 +706,7 @@ BCU_LOAD_RESULT EIB_LoadImage (EIBConnection * con, const uint8_t * image,
+  */
+ int EIB_LoadImage_async (EIBConnection * con, const uint8_t * image, int len);
+-__END_DECLS
++#ifdef __cplusplus
++}
++#endif
+ #endif