atftpd: fix conffiles
authorHuangbin Zhan <zhanhb88@gmail.com>
Sun, 24 Oct 2021 10:30:49 +0000 (18:30 +0800)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 4 Oct 2023 16:37:47 +0000 (18:37 +0200)
Add missing conffiles
Fix conffile permission

Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
(cherry picked from commit 3d66be420301bebd9cf7ee1ec26a1d08abe4a6b7)

net/atftp/Makefile

index 570a606ba86be59e97508e429be88623f05d43f6..0aa3a5ca2aa577332608a755a67ab3a9ca13e3fe 100644 (file)
@@ -56,11 +56,15 @@ define Package/atftpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/atftpd.init $(1)/etc/init.d/atftpd
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_BIN) ./files/atftpd.conf $(1)/etc/config/atftpd
+       $(INSTALL_CONF) ./files/atftpd.conf $(1)/etc/config/atftpd
        $(INSTALL_DIR) $(1)/srv/tftp
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)//usr/sbin/atftpd $(1)/usr/sbin/
 endef
 
+define Package/atftpd/conffiles
+/etc/config/atftpd
+endef
+
 $(eval $(call BuildPackage,atftp))
 $(eval $(call BuildPackage,atftpd))