xtables-addons: include xt_geoip_fetch utility
authorPhilip Prindeville <philipp@redfish-solutions.com>
Thu, 30 Apr 2020 21:37:59 +0000 (15:37 -0600)
committerPhilip Prindeville <philipp@redfish-solutions.com>
Thu, 26 Nov 2020 00:45:28 +0000 (17:45 -0700)
It's useful to be able to dump sections of the database by country
for scripting or just plain sanity checking.

Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
net/xtables-addons/Makefile

index 7c29f9de23653c1635fa09eec2f0ad30d4dcd9a7..ba531544994b5581089dd06de6cc719c7dd0a918 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=xtables-addons
 PKG_VERSION:=3.13
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_HASH:=893c0c4ea09759cda1ab7e68f1281d125e59270f7b59e446204ce686c6a76d65
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -144,6 +144,9 @@ define Package/iptgeoip/install
        $(CP) \
                $(PKG_INSTALL_DIR)/usr/lib/xtables-addons/xt_geoip_{build,dl} \
                $(1)/usr/lib/xtables-addons/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/bin/xt_geoip_fetch \
+               $(1)/usr/bin/
        $(INSTALL_DIR) $(1)/usr/share/xt_geoip
 endef