php7: fix load order of mysqli extension
authorMichael Heimpold <mhei@heimpold.de>
Tue, 3 Jul 2018 20:58:42 +0000 (22:58 +0200)
committerMichael Heimpold <mhei@heimpold.de>
Sat, 21 Jul 2018 21:42:15 +0000 (23:42 +0200)
This problem was reported by Teun Lubberhuizen, thanks!

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7/Makefile

index 8d5d7b7a62f40430655a97a7fc994a6d2e9fd200..24eb74e05067ca6c2ce619d8e1cb3309fe803604 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=7.2.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 
@@ -607,7 +607,7 @@ $(eval $(call BuildModule,intl,Internationalization Functions,+PACKAGE_php7-mod-
 $(eval $(call BuildModule,json,JSON))
 $(eval $(call BuildModule,ldap,LDAP,+PACKAGE_php7-mod-ldap:libopenldap +PACKAGE_php7-mod-ldap:libsasl2))
 $(eval $(call BuildModule,mbstring,MBString))
-$(eval $(call BuildModule,mysqli,MySQL Improved Extension,+PACKAGE_php7-mod-mysqli:php7-mod-mysqlnd))
+$(eval $(call BuildModule,mysqli,MySQL Improved Extension,+PACKAGE_php7-mod-mysqli:php7-mod-mysqlnd,30))
 $(eval $(call BuildModule,mysqlnd,MySQL Native Driver))
 $(eval $(call BuildModule,opcache,OPcache,,,zend))
 $(eval $(call BuildModule,openssl,OpenSSL,+PACKAGE_php7-mod-openssl:libopenssl))