adblock: adapt openwrt rc.common changes
authorDirk Brenken <dev@brenken.org>
Tue, 3 Nov 2020 18:51:46 +0000 (19:51 +0100)
committerDirk Brenken <dev@brenken.org>
Tue, 3 Nov 2020 18:51:46 +0000 (19:51 +0100)
* since openwrt master has merged the depending P/R, the old
extra_help/extra_commands syntax is no longer working, see #13798 for
reference

* removed test.sh script from package

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/adblock.init
net/adblock/test.sh [deleted file]

index 023fdc22fb2af53799e56ee1cdec3da486540860..e6068f7ca1679996c51faff434350f5688b10b09 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=4.0.7
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index 64dbd76845cc67726e3dee2ff1e41b446abbbfd5..c75ddee67319c0651d43968d23f208b0fab142d8 100755 (executable)
@@ -8,14 +8,13 @@
 START=30
 USE_PROCD=1
 
-EXTRA_COMMANDS="suspend resume query report list timer status_service version"
-EXTRA_HELP="   suspend Suspend adblock processing
-       resume  Resume adblock processing
-       query   <domain> Query active blocklists and backups for a specific domain
-       report  [<search>] Print DNS statistics with an optional search parameter
-       list    [[<add>|<remove>] [source(s)]] List available adblock sources or add/remove them from config
-       timer   <action> <hour> [<minute>] [<weekday>] Set a cron based update interval
-       version print version information"
+extra_command "suspend" "Suspend adblock processing"
+extra_command "resume" "Resume adblock processing"
+extra_command "query" "<domain> Query active blocklists and backups for a specific domain"
+extra_command "report" "[<search>] Print DNS statistics with an optional search parameter"
+extra_command "list" "[[<add>|<remove>] [source(s)]] List available adblock sources or add/remove them from config"
+extra_command "timer" "<action> <hour> [<minute>] [<weekday>] Set a cron based update interval"
+extra_command "version" "Print version information"
 
 adb_init="/etc/init.d/adblock"
 adb_script="/usr/bin/adblock.sh"
diff --git a/net/adblock/test.sh b/net/adblock/test.sh
deleted file mode 100755 (executable)
index 607de97..0000000
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-/etc/init.d/"${1}" version 2>/dev/null | grep "${2}"