banIP: update to 1.0.0-10
authorDirk Brenken <dev@brenken.org>
Sat, 16 Nov 2024 11:45:12 +0000 (12:45 +0100)
committerDirk Brenken <dev@brenken.org>
Wed, 27 Nov 2024 21:59:37 +0000 (22:59 +0100)
* minimal fix to support all download utilities in currently broken apk snapshots
  (see https://github.com/openwrt/openwrt/issues/16907 for details)

Signed-off-by: Dirk Brenken <dev@brenken.org>
(cherry picked from commit 4f00d8f0ee66effd40ec7c56a5a9a7395a7a8d54)

net/banip/Makefile
net/banip/files/banip-functions.sh

index 118a6fb2bac739e9a1b070239f4c46ab30de7d8b..eeb7bfd67b529299521937edda9f0aa895f3eb0a 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=banip
 PKG_VERSION:=1.0.0
-PKG_RELEASE:=9
+PKG_RELEASE:=10
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index c0a20f4441dd62b83bed4a1cddad3dea64b0af50..f5e58ccc29222d7200cc478da951047915f9520c 100644 (file)
@@ -360,10 +360,8 @@ f_actual() {
 f_getfetch() {
        local item utils insecure update="0"
 
-       if { [ "${ban_fetchcmd}" = "uclient-fetch" ] && printf "%s" "${ban_packages}" | "${ban_grepcmd}" -q '"libustream-'; } ||
-               { [ "${ban_fetchcmd}" = "wget" ] && printf "%s" "${ban_packages}" | "${ban_grepcmd}" -q '"wget-ssl'; } ||
-               [ "${ban_fetchcmd}" = "curl" ] || [ "${ban_fetchcmd}" = "aria2c" ]; then
-               ban_fetchcmd="$(f_cmd "${ban_fetchcmd}" "true")"
+       if [ -n "${ban_fetchcmd}" ]; then
+               ban_fetchcmd="$(f_cmd "${ban_fetchcmd}" optional)"
        fi
 
        if [ "${ban_autodetect}" = "1" ] && [ ! -x "${ban_fetchcmd}" ]; then