kcptun: update to version 20230207
authorDengfeng Liu <liudf0716@gmail.com>
Tue, 14 Feb 2023 05:45:21 +0000 (05:45 +0000)
committerTianling Shen <cnsztl@gmail.com>
Fri, 17 Feb 2023 07:18:00 +0000 (15:18 +0800)
add support for port-range dailer, port-range listener

Signed-off-by: Dengfeng Liu <liudf0716@gmail.com>
net/kcptun/Makefile
net/kcptun/files/kcptun.config
net/kcptun/files/kcptun.init

index ddb9935d6e3b412b44885638f062e6fb491f0e4b..18829384deee53d6c3d83e453dddaf12552b99f5 100644 (file)
@@ -1,13 +1,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=kcptun
-PKG_VERSION:=20210922
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_VERSION:=20230207
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/xtaci/kcptun/tar.gz/v${PKG_VERSION}?
-PKG_SOURCE_DATE:=2021-09-22
-PKG_HASH:=f6a08f0fe75fa85d15f9c0c28182c69a5ad909229b4c230a8cbe38f91ba2d038
+PKG_HASH:=09054b52d5799a8e47edb36f2db335d929d5bbb63a26f7ba2fe03c64ec39d550
 
 PKG_MAINTAINER:=Dengfeng Liu <liudf0716@gmail.com>, Chao Liu <expiron18@gmail.com>
 PKG_LICENSE:=MIT
index fc548ea7c1fb5f0b7d6b62d55060a1d45322a621..57ec246bae57cb2218844feeda35369d644353c1 100644 (file)
@@ -1,6 +1,6 @@
 config server
        option disabled 1
-       option listen 29900
+       option listen '29900-30000'
        option target '127.0.0.1'
        option target_port 12948
        option crypt 'aes'
@@ -23,7 +23,7 @@ config client
        option bind_address '0.0.0.0'
        option local_port 12948
        option server 'vps'
-       option server_port 29900
+       option server_port '29900-30000'
        option crypt 'aes'
        option key 'secret'
        option mode 'fast'
index 2e6c53a1d89f0dcbd192ac475d5e6bf11bf3b6ac..757510bc7d46d85f86c757651d73c5c2ae8720e8 100644 (file)
@@ -150,7 +150,7 @@ validate_common_options() {
 
 validate_server_options() {
        validate_common_options server "$@" \
-               'listen:port' \
+               'listen:or(port,portrange):29900-30000' \
                'target:host' \
                'target_port:port' \
                'pprof:bool'
@@ -161,7 +161,7 @@ validate_client_options() {
                'bind_address:ipaddr' \
                'local_port:port' \
                'server:host' \
-               'server_port:port' \
+               'server_port:or(port,portrange):29900-30000' \
                'conn:uinteger' \
                'autoexpire:uinteger' \
                'scavengettl:uinteger'