node-serialport-bindings: update to 9.0.2
authorHirokazu MORIKAWA <morikw2@gmail.com>
Wed, 11 Nov 2020 01:03:42 +0000 (10:03 +0900)
committerHirokazu MORIKAWA <morikw2@gmail.com>
Wed, 11 Nov 2020 01:03:42 +0000 (10:03 +0900)
Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node-serialport-bindings/Makefile
lang/node-serialport-bindings/patches/000-powerpc_termios_header.patch [deleted file]

index a0e71316e3e4e46fa93f97461266dac94d3d2439..f30de07129aa13711379b9af5cdd1ad0a5b7eb69 100644 (file)
@@ -7,12 +7,12 @@ include $(TOPDIR)/rules.mk
 PKG_NPM_SCOPE:=serialport
 PKG_NPM_NAME:=bindings
 PKG_NAME:=node-$(PKG_NPM_SCOPE)-$(PKG_NPM_NAME)
-PKG_VERSION:=9.0.1
+PKG_VERSION:=9.0.2
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=https://registry.npmjs.org/@$(PKG_NPM_SCOPE)/$(PKG_NPM_NAME)/-/
-PKG_HASH:=12cd7864a18d2025bf152754c019badaef387c75417fe86b9a80c86ec0ae6b49
+PKG_HASH:=03e28d0ef191f3e3f2cf9215c2f2f43106e85638a8d3bd210127781cb73ed50a
 
 PKG_BUILD_DEPENDS:=node/host
 PKG_USE_MIPS16:=0
diff --git a/lang/node-serialport-bindings/patches/000-powerpc_termios_header.patch b/lang/node-serialport-bindings/patches/000-powerpc_termios_header.patch
deleted file mode 100644 (file)
index c268f0e..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/src/serialport_linux.cpp
-+++ b/src/serialport_linux.cpp
-@@ -1,8 +1,13 @@
- #if defined(__linux__)
- #include <sys/ioctl.h>
-+#if defined(__powerpc__) || defined(__powerpc64__)
-+#include <asm-generic/ioctls.h>
-+#include <asm-generic/termbits.h>
-+#else
- #include <asm/ioctls.h>
- #include <asm/termbits.h>
-+#endif
- // Uses the termios2 interface to set nonstandard baud rates
- int linuxSetCustomBaudRate(const int fd, const unsigned int baudrate) {