php7: fix linking to libpcre
authorMichael Heimpold <mhei@heimpold.de>
Tue, 13 Feb 2018 23:30:39 +0000 (00:30 +0100)
committerMichael Heimpold <mhei@heimpold.de>
Wed, 14 Feb 2018 00:13:54 +0000 (01:13 +0100)
PHP comes with a bundled version of libpcre which is then statically
linked. However, we already depend on the packaged library, so we
can reduce the footprint when linking to it dynamically.
This saves around 200-300 kB (this depends on other configuration).

Signed-off-by: Michael Heimpold <mhei@heimpold.de>
lang/php7/Makefile

index aaee08f34a599db35c1805081f02d1dd8abadf54..996a4e2115e788990453f3b49bfb4e6a94f4d73a 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=php
 PKG_VERSION:=7.2.2
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Michael Heimpold <mhei@heimpold.de>
 
@@ -167,6 +167,7 @@ CONFIGURE_ARGS+= \
        --with-config-file-scan-dir=/etc/php7 \
        --disable-short-tags \
        \
+       --with-pcre-regex="$(STAGING_DIR)/usr" \
        --with-zlib="$(STAGING_DIR)/usr" \
          --with-zlib-dir="$(STAGING_DIR)/usr"