python: trim all whitespaces for the operator in the filespec
authorAlexandru Ardelean <aa@ocedo.com>
Tue, 6 Jan 2015 08:48:52 +0000 (10:48 +0200)
committerAlexandru Ardelean <aa@ocedo.com>
Tue, 6 Jan 2015 08:50:31 +0000 (10:50 +0200)
That would allow for files (in filespecs) to be indented.
As it is now, the files need to be added at the begginning of the line.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/files/python-package.mk

index 9a999d4f06769c71ed6f61bef532c724d6d4257d..71d500d1d77a405c50ca4bc26c9311a31f9c6ceb 100644 (file)
@@ -45,6 +45,7 @@ define PyPackage
        @echo "$$$$$$$$$$(call shvar,PyPackage/$(1)/filespec)" | ( \
                IFS='|'; \
                while read fop fspec fperm; do \
+                 fop=`echo "$$$$$$$$fop" | tr -d ' \t\n'`; \
                  if [ "$$$$$$$$fop" = "+" ]; then \
                        if [ ! -e "$(PKG_INSTALL_DIR)$$$$$$$$fspec" ]; then \
                          echo "File not found '$(PKG_INSTALL_DIR)$$$$$$$$fspec'"; \