python: add PKG_USE_MIPS16:=0 + handle CONFIG_USE_MIPS16
authorAlexandru Ardelean <aa@ocedo.com>
Wed, 5 Nov 2014 13:24:33 +0000 (15:24 +0200)
committerAlexandru Ardelean <aa@ocedo.com>
Fri, 7 Nov 2014 13:37:18 +0000 (15:37 +0200)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/files/python-package.mk

index 3f714d27f03912fbdf11b88d13d30d01f8f5addd..07f27197c2899c5f2e3122999ebf6cf414ae663d 100644 (file)
@@ -30,6 +30,13 @@ define HostPython
        )
 endef
 
+PKG_USE_MIPS16:=0
+# This is required in addition to PKG_USE_MIPS16:=0 because otherwise MIPS16
+# flags are inherited from the Python base package (via sysconfig module)
+ifdef CONFIG_USE_MIPS16
+  TARGET_CFLAGS += -mno-mips16 -mno-interlink-mips16
+endif
+
 define PyPackage
   $(call shexport,PyPackage/$(1)/filespec)