dbus: add debug compile option
authorFlorian Eckert <fe@dev.tdt.de>
Fri, 10 Dec 2021 12:50:46 +0000 (13:50 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Fri, 10 Dec 2021 14:08:51 +0000 (15:08 +0100)
To simplify the debugging of dbus problems, the VERBOSE option for the
dbus can now be switched on via make menuconfig. This is switched off by
default. If this is switched on, the dbus package must be recompiled.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/dbus/Config.in [new file with mode: 0644]
utils/dbus/Makefile

diff --git a/utils/dbus/Config.in b/utils/dbus/Config.in
new file mode 100644 (file)
index 0000000..86ceed5
--- /dev/null
@@ -0,0 +1,7 @@
+if PACKAGE_dbus
+
+config DBUS_VERBOSE
+       bool "Enable verbose error strings"
+       default n
+
+endif
index d52b25e797461c1ec601e7ba402a24e108150e99..9927f0b5947c8c03bac4f8797ff08800a484e4ee 100644 (file)
@@ -19,6 +19,9 @@ PKG_MAINTAINER:=
 PKG_LICENSE:=AFL-2.1
 PKG_CPE_ID:=cpe:/a:freedesktop:dbus
 
+PKG_CONFIG_DEPENDS:= \
+       CONFIG_DBUS_VERBOSE
+
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/cmake.mk
 
@@ -71,6 +74,10 @@ $(call Package/dbus/Default/description)
  This package contains D-Bus utilities.
 endef
 
+define Package/dbus/config
+  source "$(SOURCE)/Config.in"
+endef
+
 CMAKE_OPTIONS += \
        -DDBUS_SYSTEM_SOCKET=/var/run/dbus/system_bus_socket \
        -DDBUS_SESSION_SOCKET_DIR=/tmp \
@@ -90,6 +97,10 @@ CMAKE_OPTIONS += \
        -DDBUS_ENABLE_QTHELP_DOCS=OFF \
        -DDBUS_ENABLE_XML_DOCS=OFF
 
+ifeq ($(CONFIG_DBUS_VERBOSE),y)
+  CMAKE_OPTIONS += -DDBUS_ENABLE_VERBOSE_MODE=ON
+endif
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/dbus-1.0 $(1)/usr/include/