luasql: fix build on macos
authorSergey V. Lobanov <sergey@lobanov.in>
Fri, 7 Jan 2022 21:28:57 +0000 (00:28 +0300)
committerRosen Penev <rosenp@gmail.com>
Wed, 12 Jan 2022 00:25:33 +0000 (16:25 -0800)
luasql ./config scripts checks `uname -s` output and changes
LIB_OPTION from '-static' to macos specific if detected OS is
Darwin. These flags are not compatible with GCC

OpenWrt is always Linux, this patch removes Darwin
specific stuff from compilation flags

Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
lang/luasql/Makefile

index baea0c166de4e65f550523746b11b47a5b34adae..8c35df92140d21a5b3212266cd9277c2000ba715 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=luasql
 PKG_VERSION:=2.4.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/keplerproject/luasql/tar.gz/v$(PKG_VERSION)?
@@ -94,6 +94,7 @@ ifeq ($(BUILD_VARIANT),sqlite3)
 endif
 
 MAKE_FLAGS += \
+       LIB_OPTION="-shared" \
        CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)" \
        $(BUILD_VARIANT)