simple-adblock: add family to firewall json objects
authorStan Grishin <stangri@melmac.ca>
Sun, 7 May 2023 02:29:53 +0000 (02:29 +0000)
committerStan Grishin <stangri@melmac.ca>
Sun, 7 May 2023 02:33:12 +0000 (02:33 +0000)
Signed-off-by: Stan Grishin <stangri@melmac.ca>
(cherry picked from commit 0b84504670465876c8469da7dfb42f27d34db501)

net/simple-adblock/Makefile
net/simple-adblock/files/simple-adblock.init

index cbe16be2e136096acbf9ee01873dfbb406143868..db6e2bc5f4514d879b9ebe717dc2fdeeded0b83f 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=simple-adblock
 PKG_VERSION:=1.9.5
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.ca>
 PKG_LICENSE:=GPL-3.0-or-later
 
index 1427a7b6162273db9021feb9eefaae8c0f2cb2fc..a08dc395d626cb7d014e60e3e64265bc7bd55640 100644 (file)
@@ -1395,6 +1395,7 @@ adb_start() {
                                json_add_string proto "tcp udp"
                                json_add_string src_dport "$c"
                                json_add_string dest_port "$c"
+                               json_add_string family any
                                json_add_boolean reflection 0
                                json_close_object
                        else