node: Change icu version specification
authorHirokazu MORIKAWA <morikw2@gmail.com>
Thu, 19 Mar 2020 07:13:31 +0000 (16:13 +0900)
committerHirokazu MORIKAWA <morikw2@gmail.com>
Tue, 24 Mar 2020 04:26:34 +0000 (13:26 +0900)
modify host icu library path

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node/Makefile
lang/node/patches/999-delete_unnecessary_libraries_for_host_execute.patch

index f836f4660102fbd8c8927cab487bf872ef826051..5b368c13ea1d8594504a10708068a5cc8aceaf7b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=node
 PKG_VERSION:=v12.16.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
@@ -47,7 +47,11 @@ define Package/node/description
   Node.jsĀ® is a JavaScript runtime built on Chrome's V8 JavaScript engine. Node.js uses
   an event-driven, non-blocking I/O model that makes it lightweight and efficient. Node.js'
    package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
-  *** Requires GCC/G++ Multilib on host system to build 32-bit target ***
+  *** The following preparations must be made on the host side. ***
+      1. gcc 6.3 or higher is required.
+      2. To build a 32-bit target, gcc-multilib, g++-multilib are required.
+      3. Requires libatomic package. (If necessary, install the 32-bit library at the same time.)
+     ex) sudo apt-get install gcc-multilib g++-multilib
 endef
 
 define Package/node-npm
@@ -93,7 +97,7 @@ endif
 
 MAKE_VARS+= \
        DESTCPU=$(NODEJS_CPU) \
-       LD_LIBRARY_PATH=$(STAGING_DIR_HOSTPKG)/share/icu/65.1/lib
+       LD_LIBRARY_PATH=$(STAGING_DIR_HOSTPKG)/share/icu/current/lib
 
 CONFIGURE_VARS:= \
        CC="$(TARGET_CC) $(TARGET_OPTIMIZATION)" \
index dc473b9c7f2276459625da86d19feee141933142..36ef76f1fb80ff86be82611631bdb2e9a2ae9c9e 100644 (file)
@@ -47,7 +47,7 @@
        'target_name': 'mksnapshot',
        'type': 'executable',
 +      'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
-+      'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/65.1/lib' ],
++      'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
        'dependencies': [
          'v8_base_without_compiler',
          'v8_compiler_for_mksnapshot',
@@ -72,7 +72,7 @@
        'target_name': 'gen-regexp-special-case',
        'type': 'executable',
 +      'libraries!':[ '-lcrypto', '-lssl', '-lz', '-lhttp_parser', '-luv', '-lnghttp2', '-lcares' ],
-+      'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/65.1/lib' ],
++      'library_dirs':[ '../../../../staging_dir/hostpkg/share/icu/current/lib' ],
        'dependencies': [
          'v8_libbase',
          # "build/win:default_exe_manifest",