madplay: remove OSS variant
authorRosen Penev <rosenp@gmail.com>
Mon, 11 Jan 2021 04:29:18 +0000 (20:29 -0800)
committerRosen Penev <rosenp@gmail.com>
Mon, 11 Jan 2021 23:06:21 +0000 (15:06 -0800)
with the latest version, there's no OSS support. At least --without-oss
does not work.

Remove autoconf patches and add gettext-version fixup.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/madplay/Makefile
sound/madplay/patches/010-use_correct_shell.patch [deleted file]
sound/madplay/patches/020-no-po.patch [deleted file]

index e2a52b5488712124415176c6cc0a3f0fd9667287..d3a80fc54bfbc637676087341bbe75f9818f3950 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=madplay
 PKG_VERSION:=0.15.2b
-PKG_RELEASE:=8
+PKG_RELEASE:=9
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/mad \
@@ -20,25 +20,20 @@ PKG_MAINTAINER:=Simon Peter <probono@puredarwin.org>
 PKG_LICENSE:=GPL-2.0-or-later
 PKG_LICENSE_FILES:=COPYING
 
-PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/package.mk
 include $(INCLUDE_DIR)/nls.mk
 
-define Package/madplay/default
+define Package/madplay
   SECTION:=sound
   CATEGORY:=Sound
-  DEPENDS:=+libid3tag +libmad $(INTL_DEPENDS) $(2)
-  TITLE:=MPEG audio player in fixed point - $(1)
-  VARIANT:=$(1)
-  URL:=http://sourceforge.net/projects/mad
+  DEPENDS:=+libid3tag +libmad $(INTL_DEPENDS) +alsa-lib
+  TITLE:=MPEG audio player in fixed point - ALSA
+  URL:=https://sourceforge.net/projects/mad
 endef
 
-Package/madplay-alsa=$(call Package/madplay/default,alsa,+alsa-lib)
-Package/madplay=$(call Package/madplay/default,oss)
-
 define Package/madplay/description
        MAD is an MPEG audio decoder. It currently only supports the MPEG 1
        standard, but fully implements all three audio layers (Layer I, Layer II,
@@ -52,34 +47,17 @@ CONFIGURE_ARGS += \
        --disable-debugging \
        --disable-profiling \
        --disable-experimental \
-       --without-libiconv-prefix \
-       --without-libintl-prefix \
        --without-esd \
+       --with-alsa
 
 CONFIGURE_VARS += \
        lt_prog_compiler_pic=$(FPIC)
 
 MAKE_FLAGS += CFLAGS="$(TARGET_CFLAGS)"
 
-ifeq ($(BUILD_VARIANT),alsa)
-       CONFIGURE_ARGS += \
-               --without-oss \
-               --with-alsa
-else
-       CONFIGURE_ARGS += \
-               --without-alsa \
-               --with-oss
-endif
-
 define Package/madplay/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
 endef
 
-define Package/madplay-alsa/install
-       $(INSTALL_DIR) $(1)/usr/bin
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/madplay $(1)/usr/bin/
-endef
-
-$(eval $(call BuildPackage,madplay-alsa))
 $(eval $(call BuildPackage,madplay))
diff --git a/sound/madplay/patches/010-use_correct_shell.patch b/sound/madplay/patches/010-use_correct_shell.patch
deleted file mode 100644 (file)
index c8eb2a3..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
---- a/intl/Makefile.in
-+++ b/intl/Makefile.in
-@@ -19,7 +19,7 @@
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
--SHELL = /bin/sh
-+SHELL = @SHELL@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
-@@ -56,6 +56,7 @@ DEFS = -DLOCALEDIR=\"$(localedir)\" -DLO
- -DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"$(libdir)\" -DNO_XMALLOC \
- -Dset_relocation_prefix=libintl_set_relocation_prefix \
- -Drelocate=libintl_relocate \
-+-DINSTALLPREFIX=\"$(prefix)\" \
- -DDEPENDS_ON_LIBICONV=1 @DEFS@
- CPPFLAGS = @CPPFLAGS@
- CFLAGS = @CFLAGS@
---- a/po/Makefile.in.in
-+++ b/po/Makefile.in.in
-@@ -13,7 +13,7 @@
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
--SHELL = /bin/sh
-+SHELL = @SHELL@
- @SET_MAKE@
- srcdir = @srcdir@
diff --git a/sound/madplay/patches/020-no-po.patch b/sound/madplay/patches/020-no-po.patch
deleted file mode 100644 (file)
index bfb8c41..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -24,8 +24,8 @@
- ## Process this file with automake to produce Makefile.in
--SUBDIRS =             intl po
--DIST_SUBDIRS =                intl po m4 msvc++
-+SUBDIRS =             intl 
-+DIST_SUBDIRS =                intl m4 msvc++
- ACLOCAL_AMFLAGS =     -I m4