travelmate: Update to 1.4.4
authorDirk Brenken <dev@brenken.org>
Thu, 28 Mar 2019 19:11:26 +0000 (20:11 +0100)
committerDaniel Engberg <daniel.engberg.lists@pyret.net>
Thu, 28 Mar 2019 23:24:02 +0000 (23:24 +0000)
* refine captive portal detection/rebind protection handling,
  heavily tested with Deutsche Bahn hotspots ... ;-)
* add rebind whitelist logging

Signed-off-by: Dirk Brenken <dev@brenken.org>
Added "Update to" in commit message
Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
net/travelmate/Makefile
net/travelmate/files/travelmate.sh

index fb0c443b5a6e68a5943df62eed6c4c15079e2867..0937f656f14630ea4c0fd090fd8eefa782a14352 100644 (file)
@@ -6,7 +6,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=travelmate
-PKG_VERSION:=1.4.3
+PKG_VERSION:=1.4.4
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-3.0+
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
index cf1e17ed0f8fc873809442c908128a708c51cbcb..f541963166ac7f7a3b1e8fce27c630d3543de286 100755 (executable)
@@ -10,7 +10,7 @@
 #
 LC_ALL=C
 PATH="/usr/sbin:/usr/bin:/sbin:/bin"
-trm_ver="1.4.3"
+trm_ver="1.4.4"
 trm_sysver="unknown"
 trm_enabled=0
 trm_debug=0
@@ -242,16 +242,17 @@ f_check()
                                then
                                        result="$(${trm_fetch} --timeout=$(( ${trm_maxwait} / 3 )) "${trm_captiveurl}" -O /dev/null 2>&1 | \
                                                awk '/^Failed to redirect|^Redirected/{printf "%s" "net cp \047"$NF"\047";exit}/^Download completed/{printf "%s" "net ok";exit}/^Failed|^Connection error/{printf "%s" "net nok";exit}')"
-                                       if [ -n "${result}" ] && ([ -z "${trm_connection}" ] || [ "${result}" != "${trm_connection%/*}" ])
+                                       cp_domain="$(printf "%s" "${result}" | awk -F "['| ]" '/^net cp/{printf "%s" $4}')"
+                                       if [ -n "${result}" ] && ([ -z "${trm_connection}" ] || [ "${result}" != "${trm_connection%/*}" ] || [ -n "${cp_domain}" ])
                                        then
                                                if [ "${trm_rebind:-0}" -eq 1 ] && [ -x "/etc/init.d/dnsmasq" ]
                                                then
-                                                       cp_domain="$(printf "%s" "${result}" | awk -F "['| ]" '/^net cp/{printf "%s" $4}')"
                                                        while [ -n "${cp_domain}" ] && [ -z "$(uci_get dhcp "@dnsmasq[0]" rebind_domain | grep -Fo "${cp_domain}")" ]
                                                        do
                                                                uci -q add_list dhcp.@dnsmasq[0].rebind_domain="${cp_domain}"
                                                                uci_commit dhcp
                                                                /etc/init.d/dnsmasq reload
+                                                               f_log "info" "captive portal domain '${cp_domain}' added to rebind whitelist"
                                                                result="$(${trm_fetch} --timeout=$(( ${trm_maxwait} / 3 )) "${trm_captiveurl}" -O /dev/null 2>&1 | \
                                                                        awk '/^Failed to redirect|^Redirected/{printf "%s" "net cp \047"$NF"\047";exit}/^Download completed/{printf "%s" "net ok";exit}/^Failed|^Connection error/{printf "%s" "net nok";exit}')"
                                                                cp_domain="$(printf "%s" "${result}" | awk -F "['| ]" '/^net cp/{printf "%s" $4}')"