yate: clean up FLAGS
authorSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 13:27:40 +0000 (14:27 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sat, 3 Feb 2018 13:27:41 +0000 (14:27 +0100)
- remove flags to don't have a reason for being there anymore (there is
  no comment on why they're needed).
- add CPPFLAGS to CFLAGS so the compiler can use the FORTIFY_SOURCE
  headers.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/yate/Makefile

index c46f88d809f0704e17778c0048f1dcedc82ab30d..607384e50f0f82a06a19af7c650ed98b7c07791c 100644 (file)
@@ -82,13 +82,8 @@ define Package/$(PKG_NAME)-collection-basic
    TITLE := Basic Yate Server
 endef
 
-ifneq ($(CONFIG_USE_MUSL),)
-  LIBNSL:=
-else
-  LIBNSL:=-lnsl
-endif
-
-TARGET_CFLAGS += -I$(STAGING_DIR)/usr/include $(if $(CONFIG_BIG_ENDIAN),-DBIGENDIAN,)
+# Otherwise yate ignores CPPFLAGS
+TARGET_CFLAGS += $(TARGET_CPPFLAGS)
 
 CONFIGURE_ARGS+= \
        --enable-strings \
@@ -125,10 +120,6 @@ CONFIGURE_ARGS+= \
        --without-doxygen \
        --without-kdoc
 
-CONFIGURE_VARS+= \
-       LDFLAGS="$$$$LDFLAGS -nodefaultlibs" \
-       LIBS="-lc -luClibc++ -lpthread -lresolv -ldl -lm -lc $(LIBGCC_S) $(LIBNSL)"
-
 define Package/$(PKG_NAME)/install
        $(INSTALL_DIR) $(1)/usr/lib