collectd: make compile time debug option configurable
authorFlorian Eckert <fe@dev.tdt.de>
Mon, 8 Mar 2021 13:40:34 +0000 (14:40 +0100)
committerFlorian Eckert <fe@dev.tdt.de>
Tue, 16 Mar 2021 12:23:08 +0000 (13:23 +0100)
Enables the compiler option that collectd is compiled with
debugging support. This is used at development stages to get
more messages from the collectd during development.

This option is default disabled.

Signed-off-by: Florian Eckert <fe@dev.tdt.de>
utils/collectd/Makefile

index 3ff08596a4964a2fb76e1972597998f2590058ef..4c3a055ac8ac837a8d63cf64818145998ba1b5fc 100644 (file)
@@ -25,6 +25,10 @@ PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 PKG_USE_MIPS16:=0
 
+PKG_CONFIG_DEPENDS:= \
+       PACKAGE_COLLECTD_ENCRYPTED_NETWORK \
+       PACKAGE_COLLECTD_DEBUG_OUTPUT_ENABLE
+
 COLLECTD_PLUGINS_DISABLED:= \
        amqp \
        ampq1 \
@@ -242,12 +246,20 @@ define Package/collectd/config
        default n
        depends on PACKAGE_collectd
        select PACKAGE_collectd-mod-network
+
+       config PACKAGE_COLLECTD_DEBUG_OUTPUT_ENABLE
+       bool "Enable debug output"
+       default n
+       depends on PACKAGE_collectd
+       help
+         Enables the compiler option that collectd is compiled with
+         debugging support. This is used at development stages to get
+         more messages from the collectd during development.
 endef
 
 # common configure args
 CONFIGURE_ARGS+= \
        --disable-werror \
-       --disable-debug \
        --enable-daemon \
        --with-nan-emulation \
        --with-libyajl=no \
@@ -273,6 +285,14 @@ CONFIGURE_ARGS+= \
        --without-libgcrypt
 endif
 
+ifeq ($(CONFIG_PACKAGE_COLLECTD_DEBUG_OUTPUT_ENABLE),y)
+CONFIGURE_ARGS+= \
+       --enable-debug
+else
+CONFIGURE_ARGS+= \
+       --disable-debug
+endif
+
 CONFIGURE_PLUGIN= \
        $(foreach m, $(1), \
                $(if $(CONFIG_PACKAGE_collectd-mod-$(subst _,-,$(m))),--enable-$(m),--disable-$(m)) \