projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
9fed920
)
s390/mm: Fix ERROR: "__node_distance" undefined!
author
Justin M. Forbes
<jforbes@fedoraproject.org>
Wed, 31 Oct 2018 18:02:03 +0000
(13:02 -0500)
committer
Martin Schwidefsky
<schwidefsky@de.ibm.com>
Fri, 2 Nov 2018 07:31:57 +0000
(08:31 +0100)
Fixes:
ERROR: "__node_distance" [drivers/nvme/host/nvme-core.ko] undefined!
make[1]: *** [scripts/Makefile.modpost:92: __modpost] Error 1
make: *** [Makefile:1275: modules] Error 2
+ exit 1
Signed-off-by: Justin M. Forbes <jforbes@fedoraproject.org>
Signed-off-by: Heiko Carstens <heiko.carstens@de.ibm.com>
Signed-off-by: Martin Schwidefsky <schwidefsky@de.ibm.com>
arch/s390/numa/numa.c
patch
|
blob
|
history
diff --git
a/arch/s390/numa/numa.c
b/arch/s390/numa/numa.c
index 5bd374491f9461467790e1e0522f838827f094df..6c151b42e65db2ec8c5b81243190eac2416e4f04 100644
(file)
--- a/
arch/s390/numa/numa.c
+++ b/
arch/s390/numa/numa.c
@@
-54,6
+54,7
@@
int __node_distance(int a, int b)
{
return mode->distance ? mode->distance(a, b) : 0;
}
+EXPORT_SYMBOL(__node_distance);
int numa_debug_enabled;