toplevel.mk: add target feeds in 'make distclean'
authorThomas Richard <thomas.richard@bootlin.com>
Thu, 19 Sep 2024 10:27:27 +0000 (12:27 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 8 Oct 2024 20:50:50 +0000 (22:50 +0200)
When 'make distclean' is called, remove the target feeds.
Otherwise the directory target/linux/feeds/ (with broken symlinks) still
exists after a distclean.

Signed-off-by: Thomas Richard <thomas.richard@bootlin.com>
Link: https://patchwork.ozlabs.org/project/openwrt/patch/mailman.115093.1726741692.1280.openwrt-devel@lists.openwrt.org/
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/toplevel.mk

index 54cd8e3a908cffe09dd226c0c695d5d01c223f1f..e5f5e0fecd8de4266cc7e1e88a44082f68df49c2 100644 (file)
@@ -276,7 +276,7 @@ help:
        cat README.md
 
 distclean:
-       rm -rf bin build_dir .ccache .config* dl feeds key-build* logs package/feeds staging_dir tmp
+       rm -rf bin build_dir .ccache .config* dl feeds key-build* logs package/feeds target/linux/feeds staging_dir tmp
        @$(_SINGLE)$(SUBMAKE) -C scripts/config clean
 
 ifeq ($(findstring v,$(DEBUG)),)