golang: Install files with .cpp/.hpp suffixes by default
authorJeffery To <jeffery.to@gmail.com>
Sat, 9 Feb 2019 11:52:49 +0000 (19:52 +0800)
committerJeffery To <jeffery.to@gmail.com>
Mon, 11 Feb 2019 12:33:44 +0000 (20:33 +0800)
This also updates the URL for dh-golang.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/golang/golang-package.mk

index 4551d7b70dcda2ace6280d26ef6ffa16a791c4d3..3c1137b94d5d2378e6826c0b44024cf4c40ee15e 100644 (file)
@@ -28,7 +28,7 @@ include $(GO_INCLUDE_DIR)/golang-values.mk
 #   files are installed:
 #
 #   * Files with one of these extensions:
-#     .go, .c, .cc, .h, .hh, .proto, .s
+#     .go, .c, .cc, .cpp, .h, .hh, .hpp, .proto, .s
 #
 #   * Files in any 'testdata' directory
 #
@@ -77,7 +77,7 @@ include $(GO_INCLUDE_DIR)/golang-values.mk
 
 # Credit for this package build process (GoPackage/Build/Configure and
 # GoPackage/Build/Compile) belong to Debian's dh-golang completely.
-# https://anonscm.debian.org/cgit/pkg-go/packages/dh-golang.git
+# https://salsa.debian.org/go-team/packages/dh-golang
 
 
 # for building packages, not user code
@@ -153,7 +153,7 @@ define GoPackage/Build/Configure
                        sed 's|^\./||') ; \
                \
                if [ "$(GO_PKG_INSTALL_ALL)" != 1 ]; then \
-                       code=$$$$(echo "$$$$files" | grep '\.\(c\|cc\|go\|h\|hh\|proto\|s\)$$$$') ; \
+                       code=$$$$(echo "$$$$files" | grep '\.\(c\|cc\|cpp\|go\|h\|hh\|hpp\|proto\|s\)$$$$') ; \
                        testdata=$$$$(echo "$$$$files" | grep '\(^\|/\)testdata/') ; \
                        \
                        for pattern in $(GO_PKG_INSTALL_EXTRA); do \