projects
/
openwrt
/
staging
/
blogic.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
73679e5
)
x86/build: Supress realmode.bin is up to date message
author
Peter Foley
<pefoley2@pefoley.com>
Tue, 15 Apr 2014 17:58:13 +0000
(13:58 -0400)
committer
Ingo Molnar
<mingo@kernel.org>
Wed, 16 Apr 2014 13:17:24 +0000
(15:17 +0200)
Supress this unnecessary message during kernel re-build:
make[3]: 'arch/x86/realmode/rm/realmode.bin' is up to date.
Signed-off-by: Peter Foley <pefoley2@pefoley.com>
Link:
http://lkml.kernel.org/r/1397584693-15902-1-git-send-email-pefoley2@pefoley.com
Signed-off-by: Ingo Molnar <mingo@kernel.org>
arch/x86/realmode/rm/Makefile
patch
|
blob
|
history
diff --git
a/arch/x86/realmode/rm/Makefile
b/arch/x86/realmode/rm/Makefile
index 3497f14e4dea8acd074ae0c1d6e03836de2623a1..7c0d7be176a5843932cb3d8b84ebae04e5ac4827 100644
(file)
--- a/
arch/x86/realmode/rm/Makefile
+++ b/
arch/x86/realmode/rm/Makefile
@@
-52,8
+52,9
@@
$(obj)/realmode.elf: $(obj)/realmode.lds $(REALMODE_OBJS) FORCE
OBJCOPYFLAGS_realmode.bin := -O binary
targets += realmode.bin
-$(obj)/realmode.bin: $(obj)/realmode.elf $(obj)/realmode.relocs
+$(obj)/realmode.bin: $(obj)/realmode.elf $(obj)/realmode.relocs
FORCE
$(call if_changed,objcopy)
+ @:
quiet_cmd_relocs = RELOCS $@
cmd_relocs = arch/x86/tools/relocs --realmode $< > $@