python: remove readline.so for now
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Sun, 9 Nov 2014 17:54:01 +0000 (19:54 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Sun, 9 Nov 2014 18:16:25 +0000 (20:16 +0200)
Some symbols are not found (tgetnum and BC).
Looks like the termcap lib, which should be in libncurses(w)
but maybe some build param would be required.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/Makefile

index 38e9267f9e826fc9ae8a86d86d4d567fa5a74740..bab6ce33592b45cadc63d79421918cd37881b730 100644 (file)
@@ -64,7 +64,7 @@ endef
 
 define Package/python
 $(call Package/python/Default)
-  DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libreadline +libsqlite3 +libexpat +libdb47
+  DEPENDS:=+python-base +libncursesw +libbz2 +libgdbm +libsqlite3 +libexpat +libdb47
 endef
 
 define Package/python/description
@@ -159,6 +159,7 @@ define PyPackage/python/filespec
 -|/usr/lib/python$(PYTHON_VERSION)/webbrowser.py
 -|/usr/lib/python$(PYTHON_VERSION)/*/test
 -|/usr/lib/python$(PYTHON_VERSION)/*/tests
+-|/usr/lib/python$(PYTHON_VERSION)/lib-dynload/readline.so
 endef
 
 define PyPackage/python-base/install