build: replace uses of OpenWrt with $(VERSION_DIST)
authorFelix Fietkau <nbd@nbd.name>
Wed, 8 Nov 2017 17:40:37 +0000 (18:40 +0100)
committerFelix Fietkau <nbd@nbd.name>
Tue, 12 Dec 2017 11:46:04 +0000 (12:46 +0100)
This makes the distribution name more configurable.

Signed-off-by: Felix Fietkau <nbd@nbd.name>
13 files changed:
include/image-commands.mk
include/image.mk
target/linux/apm821xx/image/Makefile
target/linux/ar71xx/image/generic.mk
target/linux/ar71xx/image/legacy.mk
target/linux/ar71xx/image/senao.mk
target/linux/ar71xx/image/tp-link.mk
target/linux/ath25/image/Makefile
target/linux/brcm63xx/image/bcm63xx.mk
target/linux/cns3xxx/image/Makefile
target/linux/lantiq/image/Makefile
target/linux/mcs814x/image/Makefile
target/linux/ramips/image/Makefile

index 5f0ac6164d9241a2d89314dca1b8d134bd8c3d4d..4b29695d9a69c4a8c2fd9b275834b79a0f1cf149 100644 (file)
@@ -7,7 +7,7 @@ define Build/uImage
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION))' -d $@ $@.new
+               -n '$(if $(UIMAGE_NAME),$(UIMAGE_NAME),$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION))' -d $@ $@.new
        mv $@.new $@
 endef
 
@@ -60,7 +60,7 @@ endef
 
 define Build/netgear-dni
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(NETGEAR_BOARD_ID) -v OpenWrt.$(REVISION) \
+               -B $(NETGEAR_BOARD_ID) -v $(VERSION_DIST).$(REVISION) \
                $(if $(NETGEAR_HW_ID),-H $(NETGEAR_HW_ID)) \
                -r "$(1)" \
                -i $@ -o $@.new
@@ -83,7 +83,7 @@ define Build/append-uImage-fakeroot-hdr
        rm -f $@.fakeroot
        $(STAGING_DIR_HOST)/bin/mkimage \
                -A $(LINUX_KARCH) -O linux -T filesystem -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt fakeroot' \
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) fakeroot' \
                -s \
                $@.fakeroot
        cat $@.fakeroot >> $@
index 605cb066729324f9dd5d165857544d6a6757d2ab..7635063c2778db59ae2c892f8a8760f933e5d6a8 100644 (file)
@@ -136,7 +136,7 @@ endef
 
 define Image/BuildKernel/MkuImage
        mkimage -A $(ARCH) -O linux -T kernel -C $(1) -a $(2) -e $(3) \
-               -n '$(call toupper,$(ARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $(4) $(5)
+               -n '$(call toupper,$(ARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(4) $(5)
 endef
 
 define Image/BuildKernel/MkFIT
index ee85292d57dd9aa8acf254b2ddd138b86ee77f06..58ea2945f45d09c1380c83a3cca07fda1f480f38 100644 (file)
@@ -116,7 +116,7 @@ define Build/create-uImage-dtb
        # flat_dt target expect FIT image - which WNDR4700's uboot doesn't support
        -$(STAGING_DIR_HOST)/bin/mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel -C none \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' \
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(IMAGE_KERNEL).dtb $@.new
        @mv $@.new $@
 endef
index 58eb3fd9225f5e2591459c122fc764e4fc99b9c8..2cd579f1b9c16934c0fa746ada8060219a937da5 100644 (file)
@@ -12,7 +12,7 @@ define Build/mkwrggimg
        $(STAGING_DIR_HOST)/bin/mkwrggimg -b \
                -i $@ -o $@.imghdr -d /dev/mtdblock/1 \
                -m $(BOARDNAME) -s $(DAP_SIGNATURE) \
-               -v OpenWrt -B $(REVISION)
+               -v $(VERSION_DIST) -B $(REVISION)
        mv $@.imghdr $@
 endef
 
@@ -30,7 +30,7 @@ define Build/netgear-squashfs
                -A mips -O linux -T filesystem -C none \
                -M $(NETGEAR_KERNEL_MAGIC) \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $@.squashfs $@
        rm -rf $@.squashfs $@.fs
 endef
@@ -66,7 +66,7 @@ define Build/uImageHiWiFi
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+               -n 'tw150v1 $(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $@ $@.new
        @mv $@.new $@
 endef
 
index 01d7e50631a3e4f886df41017df2e1e706c73710..7033b454484c56c3e1158632d39acea3838a1c2b 100644 (file)
@@ -87,7 +87,7 @@ ifneq ($(SUBTARGET),mikrotik)
 # $(4): output file.
 define MkuImage
        mkimage -A mips -O linux -T kernel -a 0x80060000 -C $(1) $(2) \
-               -e 0x80060000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e 0x80060000 -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(3) $(4)
 endef
 
@@ -485,11 +485,11 @@ define Image/Build/Belkin
        $(eval rootsize=$(call mtdpartsize,rootfs,$(4)))
        $(call Sysupgrade/RKuImage,$(1),$(2),$(kernsize),$(rootsize))
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
-               edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+               edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
                        -n "uImage" \
                        -i $(KDIR_TMP)/vmlinux-$(2).uImage \
                        -o $(KDIR_TMP)/$(2)-uImage; \
-               edimax_fw_header -m $(5) -v "$(shell echo -n OpenWrt$(REVISION) | cut -c -13)" \
+               edimax_fw_header -m $(5) -v "$(shell echo -n $(VERSION_DIST)$(REVISION) | cut -c -13)" \
                        -n "rootfs" \
                        -i $(KDIR)/root.$(1) \
                        -o $(KDIR_TMP)/$(2)-rootfs; \
@@ -662,7 +662,7 @@ define Image/Build/Netgear/buildkernel
        ) > $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2
        mkimage -A mips -O linux -T filesystem -C none -M $(5) \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -n 'MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)' \
                -d $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs.tmp2 \
                $(KDIR_TMP)/vmlinux-$(2).uImage.squashfs
 endef
@@ -674,7 +674,7 @@ define Image/Build/Netgear
                for r in $(7) ; do \
                        [ -n "$$r" ] && dashr="-$$r" || dashr= ; \
                        $(STAGING_DIR_HOST)/bin/mkdniimg \
-                               -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+                               -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
                                -i $(call sysupname,$(1),$(2)) \
                                -o $(call imgname,$(1),$(2))-factory$$dashr.img; \
                done; \
@@ -715,7 +715,7 @@ define Image/Build/NetgearNAND/buildkernel
        dd if=/dev/zero of=$(KDIR_TMP)/fakeroot-$(2) bs=131072 count=1
        mkimage -A mips -O linux -T filesystem -C none \
                -a 0xbf070000 -e 0xbf070000 \
-               -n 'MIPS OpenWrt fakeroot' \
+               -n 'MIPS $(VERSION_DIST) fakeroot' \
                -d $(KDIR_TMP)/fakeroot-$(2) \
                -M $(5) \
                $(KDIR_TMP)/fakeroot-$(2).uImage
@@ -746,7 +746,7 @@ define Image/Build/NetgearNAND
                dd if=$(KDIR_TMP)/$(2)-root.ubi \
        ) > $(imageraw)
        $(STAGING_DIR_HOST)/bin/mkdniimg \
-               -B $(6) -v OpenWrt.$(REVISION) -r "$$r" $(8) \
+               -B $(6) -v $(VERSION_DIST).$(REVISION) -r "$$r" $(8) \
                -i $(imageraw) \
                -o $(call imgname,ubi,$(2))-factory.img
 
index dbb7b69f94735ffe148e851fabd7d2b837f47532..f400dfa2da97610c5f16f9dabee7fdd1ec3b5b91 100644 (file)
@@ -4,7 +4,7 @@ define Build/senao-factory-image
 
        mkdir -p $@.senao
 
-       touch $@.senao/FWINFO-OpenWrt-$(REVISION)-$(board)
+       touch $@.senao/FWINFO-$(VERSION_DIST)-$(REVISION)-$(board)
        $(CP) $(IMAGE_KERNEL) $@.senao/openwrt-senao-$(board)-uImage-lzma.bin
        $(CP) $(rootfs) $@.senao/openwrt-senao-$(board)-root.squashfs
 
index f21d0d7f799bee438ba62cdbe602a73d4537dbdf..1194478690348997ddee851c91d0ea66916dae80 100644 (file)
@@ -24,7 +24,7 @@ endef
 # -X reserve <size> bytes in the firmware image (hexval prefixed with 0x)
 define Build/mktplinkfw
        -$(STAGING_DIR_HOST)/bin/mktplinkfw \
-               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+               -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N $(VERSION_DIST) -V $(REVISION) \
                -m $(TPLINK_HEADER_VERSION) \
                -k $(IMAGE_KERNEL) \
                -r $@ \
@@ -39,7 +39,7 @@ define Build/uImageArcher
        mkimage -A $(LINUX_KARCH) \
                -O linux -T kernel \
                -C $(1) -a $(KERNEL_LOADADDR) -e $(if $(KERNEL_ENTRY),$(KERNEL_ENTRY),$(KERNEL_LOADADDR)) \
-               -n '$(call toupper,$(LINUX_KARCH)) OpenWrt Linux-$(LINUX_VERSION)' -d $@ $@.new
+               -n '$(call toupper,$(LINUX_KARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $@ $@.new
        @mv $@.new $@
 endef
 
index 5144ed8a0a9c5b3f53dff50b6e38b8cea34c0f5e..5a20bdb64454459cdc90119b979428a5e6427d15 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 define Build/mkfwimage
        $(STAGING_DIR_HOST)/bin/mkfwimage \
-               -B $(1).OpenWrt.$(REVISION) \
+               -B $(1).$(VERSION_DIST).$(REVISION) \
                -k $(IMAGE_KERNEL) \
                -r $(IMAGE_ROOTFS) \
                -o $@.new && \
index 4e90eb0504ead8c04f69c0ea26fedf7100ee31e4..99d479c732dd08d6d7001e7deda509b9f94047d8 100644 (file)
@@ -978,7 +978,7 @@ define Device/NEUFBOX4-SER
   DEVICE_DTS := nb4-ser-r0
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -990,7 +990,7 @@ define Device/NEUFBOX4-FXC
   DEVICE_DTS := nb4-fxc-r1
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -1002,7 +1002,7 @@ define Device/NEUFBOX6
   DEVICE_DTS := nb6-ser-r0
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
-  CFE_EXTRAS += --rsa-signature "OpenWrt-$(firstword $(subst -,$(space),$(REVISION)))"
+  CFE_EXTRAS += --rsa-signature "$(VERSION_DIST)-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
index 99bb7f1a22b411597589401ab676b098500571ad..d095ce11f46516ef5f479ac58570e584cb2ba133 100644 (file)
@@ -8,7 +8,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
 define Image/Prepare
-       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
+       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage $(KDIR)/uImage
 endef
 
 LEGACY_NOR_KERNEL_SIZE = 2048k
@@ -27,7 +27,7 @@ define BuildFirmware/Legacy
 endef
 
 define Image/BuildKernel/Initramfs
-       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n 'OpenWrt Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
+       mkimage -A arm -O linux -T kernel -C none -a 0x20008000 -e 0x20008000 -n '$(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(KDIR)/zImage-initramfs $(BIN_DIR)/$(IMG_PREFIX)-initramfs-uImage
 endef
 
 define Image/Build
index 596c46110fb7184aba2ae6d5384d7d7a416913a5..2c90163add36fa153a4d2a597f37d19862a4fc06 100644 (file)
@@ -39,7 +39,7 @@ endef
 
 define Build/fullimage
        mkimage -A mips -O linux -C lzma -T filesystem -a 0x00  \
-               -e 0x00 -n 'OpenWrt RootFS' \
+               -e 0x00 -n '$(VERSION_DIST) RootFS' \
                -d $(IMAGE_ROOTFS) $(IMAGE_ROOTFS).new
 
        cat $(IMAGE_KERNEL) $(IMAGE_ROOTFS).new > $@.tmp
index 3afd660c14ffb875c124730cd8f5ceb21b3e2093..ff905b30857ae906815ed4870db5e70d270bb920 100644 (file)
@@ -20,7 +20,7 @@ UIMAGE:=$(BIN_DIR)/$(IMG_PREFIX)-uImage
 
 define Image/Build/MkuImage
        mkimage -A arm -O linux -T kernel -a $(LOADADDR) -C none -e $(LOADADDR) \
-       -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' -d $(1) $(2);
+       -n 'ARM $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(1) $(2);
 endef
 
 define Image/Build/DTB
index c70761b250fed3a2ec3ca8d60b869b83b434db0c..ddd037e3052211d70c46968c80b791fc479ed3b9 100644 (file)
@@ -118,7 +118,7 @@ endef
 # $(2), filename of image data
 # $(3), output filename
 define MkImage
-       $(eval imagename=$(if $(4),$(4),MIPS OpenWrt Linux-$(LINUX_VERSION)))
+       $(eval imagename=$(if $(4),$(4),MIPS $(VERSION_DIST) Linux-$(LINUX_VERSION)))
        -mkimage -A mips -O linux -T kernel -C $(1) -a $(loadaddr-y) -e $(loadaddr-y) \
                -n "$(imagename)" \
                -d $(2) $(3)