openpyxl: bump to version 3.0.3
authorAlexandru Ardelean <ardeleanalex@gmail.com>
Mon, 18 Nov 2019 14:28:39 +0000 (16:28 +0200)
committerAlexandru Ardelean <ardeleanalex@gmail.com>
Thu, 16 Apr 2020 12:22:44 +0000 (15:22 +0300)
Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
lang/python/openpyxl/Makefile

index 4d292d7f4bde4846abfe498875e96a72d989e795..77cad3be0e715c64b30091a7d83a49949c0b307b 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-openpyxl
-PKG_VERSION:=2.6.2
+PKG_VERSION:=3.0.3
 PKG_RELEASE:=1
 
 PKG_MAINTAINER:=Alexandru Ardelean <ardeleanalex@gmail.com>
@@ -16,27 +16,19 @@ PKG_LICENSE:=MIT
 PKG_LICENSE_FILES:=LICENCE.rst
 
 PYPI_NAME:=openpyxl
-PKG_HASH:=1d2af392cef8c8227bd2ac3ebe3a28b25aba74fd4fa473ce106065f0b73bfe2e
+PKG_HASH:=547a9fc6aafcf44abe358b89ed4438d077e9d92e4f182c87e2dc294186dc4b64
 
 include ../pypi.mk
 include $(INCLUDE_DIR)/package.mk
 include ../python3-package.mk
 
-define Package/python-openpyxl/Default
+define Package/python3-openpyxl
   SUBMENU:=Python
   SECTION:=lang
   CATEGORY:=Languages
   TITLE:=A Python library to read/write Excel 2010 xlsx/xlsm files
   URL:=https://openpyxl.readthedocs.org/
-endef
-
-define Package/python3-openpyxl
-  $(call Package/python-openpyxl/Default)
-  DEPENDS:= \
-       +PACKAGE_python3-openpyxl:python3 \
-       +PACKAGE_python3-openpyxl:python3-defusedxml \
-       +PACKAGE_python3-openpyxl:python3-et_xmlfile \
-       +PACKAGE_python3-openpyxl:python3-jdcal
+  DEPENDS:=+python3 +python3-defusedxml +python3-et_xmlfile +python3-jdcal
   VARIANT:=python3
 endef