ffmpeg: add libopus support
authorIan Leonard <antonlacon@gmail.com>
Thu, 28 Aug 2014 20:16:59 +0000 (13:16 -0700)
committerIan Leonard <antonlacon@gmail.com>
Sun, 12 Oct 2014 05:13:15 +0000 (22:13 -0700)
Signed-off-by: Ian Leonard <antonlacon@gmail.com>
multimedia/ffmpeg/Config.in
multimedia/ffmpeg/Makefile

index 3e6e2091d2974c7698f2d234f2f4007cf1235de4..c014987781555297ae27fddbcfdc31cc13508e4c 100644 (file)
@@ -60,6 +60,7 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
        select FFMPEG_CUSTOM_DECODER_ape
        select FFMPEG_CUSTOM_DECODER_atrac3
        select FFMPEG_CUSTOM_DECODER_flac
+       select FFMPEG_CUSTOM_SELECT_libopus
        select FFMPEG_CUSTOM_DECODER_mp2
        select FFMPEG_CUSTOM_DECODER_mp3
        select FFMPEG_CUSTOM_DECODER_mpc7
@@ -108,6 +109,9 @@ config FFMPEG_CUSTOM_AUDIO_DEC_SUPPORT
 
 comment "External Libraries ---"
 
+config FFMPEG_CUSTOM_SELECT_libopus
+       bool "Opus"
+
 config FFMPEG_CUSTOM_SELECT_speex
        bool "Speex"
 
index 3923cc820684bd07bcafa7d6896b8ab597455d7d..ab1beb640a44a5a1165db6669d1c7eb07424b379 100644 (file)
@@ -289,7 +289,7 @@ endef
 define Package/libffmpeg-custom
 $(call Package/libffmpeg/Default)
  TITLE+= (custom)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
  VARIANT:=custom
  MENU:=1
 endef
@@ -308,7 +308,7 @@ endef
 define Package/libffmpeg-audio-dec
 $(call Package/libffmpeg/Default)
  TITLE+= (audio)
- DEPENDS+= @DEVEL +libspeex
+ DEPENDS+= @DEVEL +libopus +libspeex
  VARIANT:=audio-dec
 endef
 
@@ -428,6 +428,12 @@ ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_adpcm),y)
 
 endif
 
+ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_libopus),y)
+  FFMPEG_CONFIGURE+= \
+       --enable-libopus --enable-decoder=libopus \
+
+endif
+
 ifeq ($(CONFIG_FFMPEG_CUSTOM_SELECT_speex),y)
   FFMPEG_CONFIGURE+= \
        --enable-libspeex --enable-decoder=libspeex \
@@ -454,6 +460,7 @@ ifeq ($(BUILD_VARIANT),audio-dec)
        $(call FFMPEG_ENABLE,demuxer,$(FFMPEG_AUDIO_DEMUXERS)) \
        $(call FFMPEG_ENABLE,parser,$(FFMPEG_AUDIO_PARSERS)) \
        $(call FFMPEG_ENABLE,protocol,$(FFMPEG_AUDIO_PROTOCOLS)) \
+       --enable-libopus --enable-decoder=libopus \
        --enable-libspeex --enable-decoder=libspeex \
        --disable-decoder=pcm_bluray,pcm_dvd \