mtr: update to 0.93
authorDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Tue, 10 Dec 2019 12:04:47 +0000 (20:04 +0800)
committerDENG Qingfang <dengqf6@mail2.sysu.edu.cn>
Thu, 12 Dec 2019 15:22:43 +0000 (23:22 +0800)
Update mtr to 0.93
Add size optimization options
ath79 ipk size: 31.9k -> 31.4k

Signed-off-by: DENG Qingfang <dengqf6@mail2.sysu.edu.cn>
net/mtr/Makefile

index ce62d3ccfaa164644a6fafa2386924c5d898e92f..b77a7db277979e71a206f8f170e45b1d6c94d4b1 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mtr
-PKG_VERSION:=0.92
-PKG_RELEASE:=6
+PKG_VERSION:=0.93
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://www.bitwizard.nl/mtr/files
-PKG_HASH:=f2979db9e2f41aa8e6574e7771767c9afe111d9213814eb47f5e1e71876e4382
+PKG_SOURCE_URL:=ftp://ftp.bitwizard.nl/mtr
+PKG_HASH:=229c673d637bd7dbb96471623785a47e85da0b1944978200c949994c1e6af10d
 
 PKG_MAINTAINER:=Jonathan McCrohan <jmccrohan@gmail.com>
 PKG_LICENSE:=GPL-2.0-or-later
@@ -23,20 +23,8 @@ PKG_CPE_ID:=cpe:/a:matt_kimball_and_roger_wolff:mtr
 PKG_INSTALL:=1
 PKG_BUILD_PARALLEL:=1
 
-PKG_FIXUP:=autoreconf
-
 include $(INCLUDE_DIR)/package.mk
 
-# Creation of .tarball-version is an attempt to make it explicit to configure
-# script the program version.  See discussions at link [1] for more details
-#
-#  [1] mtr: add autoreconf, https://github.com/openwrt/packages/pull/6962#issuecomment-419156300
-#
-define Build/Prepare
-       $(call Build/Prepare/Default)
-       echo "$(PKG_VERSION)" >$(PKG_BUILD_DIR)/.tarball-version
-endef
-
 define Package/mtr
   SECTION:=net
   CATEGORY:=Network
@@ -56,6 +44,9 @@ define Package/mtr/description
        running statistics about each machine.
 endef
 
+TARGET_CFLAGS += -ffunction-sections -fdata-sections
+TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
+
 CONFIGURE_ARGS += \
        --without-gtk \
        $(call autoconf_bool,CONFIG_IPV6,ipv6)