sshtunnel: correct access of config file
authorRosen Penev <rosenp@gmail.com>
Mon, 24 Aug 2020 20:49:45 +0000 (13:49 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 24 Aug 2020 20:49:45 +0000 (13:49 -0700)
With this change the `/etc/config/sshtunnel` file has the correct access.
It's a sensible file.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/sshtunnel/Makefile

index 4fcb6817fb573c6e21738e5a67c4719bfc267cba..67273109b63ad5418c8e6be6ac5d842294ee7c52 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=sshtunnel
 PKG_VERSION:=4
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 PKG_LICENSE:=GPL-2.0-or-later
 
 PKG_MAINTAINER:=Nuno Goncalves <nunojpg@gmail.com>
@@ -40,7 +40,7 @@ define Package/sshtunnel/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_BIN) ./files/sshtunnel.init $(1)/etc/init.d/sshtunnel
        $(INSTALL_DIR) $(1)/etc/config
-       $(INSTALL_DATA) ./files/uci_sshtunnel $(1)/etc/config/sshtunnel
+       $(INSTALL_CONF) ./files/uci_sshtunnel $(1)/etc/config/sshtunnel
 endef
 
 $(eval $(call BuildPackage,sshtunnel))