procps-ng: remove unnecessary PKG_BUILD_DEPENDS
authorIan Cooper <iancooper@hotmail.com>
Wed, 29 Apr 2020 10:07:36 +0000 (11:07 +0100)
committerIan Cooper <iancooper@hotmail.com>
Wed, 29 Apr 2020 10:08:17 +0000 (11:08 +0100)
The package Makefile contains an unnecessary PKG_BUILD_DEPENDS
line that builds gettext and libiconv even in cases where the
build has gettext-full and libiconv-full selected.

This behaviour can and does mask errors in other package Makefiles
that are dependent on libiconv-full if it is compiled before
these packages by causing libiconv-stub to be created and put in
the staging tree and potentially linked against by these
dependent packages when they omit to specify an appropriate
PKG_BUILD_DEPENDS line.

procps-ng does not require gettext or libiconv to be built in
order to compile correctly.

Signed-off-by: Ian Cooper <iancooper@hotmail.com>
utils/procps-ng/Makefile

index fb9a4e69de3f3ab7ae4e579faea081a9f9194f7b..31adc9b566fb6fb839fd351355e765b6c29750e2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procps-ng
 PKG_VERSION:=3.3.15
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@SF/procps-ng
@@ -22,7 +22,6 @@ PKG_LICENSE_FILES:=COPYING COPYING.LIB
 PKG_BUILD_PARALLEL:=1
 PKG_INSTALL:=1
 PKG_FIXUP:=autoreconf
-PKG_BUILD_DEPENDS:=gettext libiconv
 
 include $(INCLUDE_DIR)/package.mk