loudmouth: Disable debug and fix no deprecated API compilation
authorRosen Penev <rosenp@gmail.com>
Tue, 27 Nov 2018 17:41:55 +0000 (09:41 -0800)
committerRosen Penev <rosenp@gmail.com>
Tue, 23 Jul 2019 03:10:52 +0000 (20:10 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from 788fda356e209a17095e185c166cd8f3f9a61688)

libs/loudmouth/Makefile
libs/loudmouth/patches/020-openssl-deprecated.patch [new file with mode: 0644]

index fe572c2370b430a92ed52b7430f90a397cf6ead8..bb67bcfc4e5fabcf60ade42616b173110f2d21b9 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=loudmouth
 PKG_VERSION:=1.5.3
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org>
 
@@ -46,6 +46,10 @@ CONFIGURE_ARGS += \
        --without-idn \
        --with-ssl=openssl
 
+CONFIGURE_VARS += \
+       ac_cv_lib_crypto_BIO_f_base64=yes \
+       ac_cv_lib_ssl_SSL_new=yes
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(CP) \
diff --git a/libs/loudmouth/patches/020-openssl-deprecated.patch b/libs/loudmouth/patches/020-openssl-deprecated.patch
new file mode 100644 (file)
index 0000000..976d9b9
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/loudmouth/lm-ssl-openssl.c
++++ b/loudmouth/lm-ssl-openssl.c
+@@ -345,9 +345,11 @@ _lm_ssl_initialize (LmSSL *ssl)
+     /*const char *cert_file = NULL;*/
+     if (!initialized) {
++#if OPENSSL_VERSION_NUMBER < 0x10100000L
+         SSL_library_init();
+         /* FIXME: Is this needed when we are not in debug? */
+         SSL_load_error_strings();
++#endif
+         initialized = TRUE;
+     }