openvswitch: bump to version 2.17.0
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 23 Mar 2022 06:47:41 +0000 (06:47 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 24 Mar 2022 04:53:31 +0000 (12:53 +0800)
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
net/openvswitch/Makefile
net/openvswitch/openvswitch.mk
net/openvswitch/patches/0001-netdev-linux-Let-interface-flag-survive-internal-por.patch
net/openvswitch/patches/0002-python-separate-host-target-python-for-cross-compile.patch
net/openvswitch/patches/0007-build-only-link-libopenvswitch-with-libunwind-libunb.patch

index e6a23aadc4bc4a030a902ffaaa1c7703f664aa76..a10fb8572da73a9841ceffe92fdd0bf0a2d57561 100644 (file)
@@ -20,7 +20,7 @@ PKG_VERSION:=$(ovs_version)
 PKG_RELEASE:=$(AUTORELEASE)
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://www.openvswitch.org/releases/
-PKG_HASH:=015e77a520c380b080b3fb5a4c73e34ef40c08aa05d7049c73719db75b6adc79
+PKG_HASH:=e03bfab7ca82d81a7d3a36de4f390a3b5210e3f39657671f922877cd4ea6dc73
 
 PKG_LICENSE:=Apache-2.0
 PKG_LICENSE_FILES:=LICENSE
index dd57c6369cfffddfe15b92a2c9575cfb1af8a0b8..c3e6176e03cffdb378789bf5cc08a6ba6b119567 100644 (file)
@@ -5,7 +5,7 @@
 
 # Versions
 
-ovs_version:=2.15.3
+ovs_version:=2.17.0
 ovs_builddir=$(KERNEL_BUILD_DIR)/openvswitch-$(ovs_version)
 
 # Shared vars, macros
index 6a22077a25b8de3d2a7c6dca5d34a3429c764d41..80b11dc07e5d781a7e3cdec4d5612ac1248d865a 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Helmut Schaa <helmut.schaa@googlemail.com>
 
 --- a/lib/netdev-linux.c
 +++ b/lib/netdev-linux.c
-@@ -3485,7 +3485,13 @@ update_flags(struct netdev_linux *netdev
+@@ -3546,7 +3546,13 @@ update_flags(struct netdev_linux *netdev
      unsigned int old_flags, new_flags;
      int error = 0;
  
index 434b56e670e5944c575ce19969dda33c73866f62..e44b6466d2550113e284fde7742d1e07995ca471 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
  BUILT_SOURCES =
 --- a/m4/openvswitch.m4
 +++ b/m4/openvswitch.m4
-@@ -372,6 +372,8 @@ else:
+@@ -400,6 +400,8 @@ else:
       AC_MSG_ERROR([Python 3.4 or later is required but not found in $PATH, please install it or set $PYTHON3 to point to it])
     fi
     AC_ARG_VAR([PYTHON3])
index 1491af51d5cc254090b4bbe950be125adebdf146..d37733223eb434c59467b85754eb3e69fd28b48d 100644 (file)
@@ -32,7 +32,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
  Cflags: -I${includedir}/openvswitch
 --- a/m4/openvswitch.m4
 +++ b/m4/openvswitch.m4
-@@ -646,7 +646,8 @@ AC_DEFUN([OVS_CHECK_UNBOUND],
+@@ -677,7 +677,8 @@ AC_DEFUN([OVS_CHECK_UNBOUND],
    [AC_CHECK_LIB(unbound, ub_ctx_create, [HAVE_UNBOUND=yes], [HAVE_UNBOUND=no])
     if test "$HAVE_UNBOUND" = yes; then
       AC_DEFINE([HAVE_UNBOUND], [1], [Define to 1 if unbound is detected.])
@@ -42,7 +42,7 @@ Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
     fi
     AM_CONDITIONAL([HAVE_UNBOUND], [test "$HAVE_UNBOUND" = yes])
     AC_SUBST([HAVE_UNBOUND])])
-@@ -658,7 +659,8 @@ AC_DEFUN([OVS_CHECK_UNWIND],
+@@ -689,7 +690,8 @@ AC_DEFUN([OVS_CHECK_UNWIND],
     [HAVE_UNWIND=no])
     if test "$HAVE_UNWIND" = yes; then
       AC_DEFINE([HAVE_UNWIND], [1], [Define to 1 if unwind is detected.])